Jvm uses the client vm, make sure to run `java` with the server vm for best performance by adding `-server` to the command line


(Kuido Kuido) #1

Hello

I'm trying to start Java in Server VM mode for elasticsearch but no
success

Ubuntu 10.04.4 LTS

/etc/environment file is set environment variable
ES_JAVA_OPTS="-server"

echo $ES_JAVA_OPTS shows
-server

in elasticsearch.conf file
set.default.ES_JAVA_OPTS=-server

java -showversion -server
java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.13)
(6b20-1.9.13-0ubuntu1~10.04.1)
OpenJDK Server VM (build 19.0-b09, mixed mode)

but in elasticsearch,conf file is still error
[WARN ][bootstrap ] jvm uses the client vm, make sure
to run java with the server vm for best performance by adding - server to the command line

Which is the correct place to put -server command line option ?

Kuido


(Shay Banon) #2

If you run it without the wrapper does it work? You can't set the
ES_JAVA_OPTS with teh Java service wrapper, you might need to add it
explicitly in the JVM configs later on in the wrapper configuration.

On Thu, Apr 5, 2012 at 11:57 PM, Kuido Kuido kuido20@yahoo.com wrote:

Hello

I'm trying to start Java in Server VM mode for elasticsearch but no
success

Ubuntu 10.04.4 LTS

/etc/environment file is set environment variable
ES_JAVA_OPTS="-server"

echo $ES_JAVA_OPTS shows
-server

in elasticsearch.conf file
set.default.ES_JAVA_OPTS=-server

java -showversion -server
java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.13)
(6b20-1.9.13-0ubuntu1~10.04.1)
OpenJDK Server VM (build 19.0-b09, mixed mode)

but in elasticsearch,conf file is still error
[WARN ][bootstrap ] jvm uses the client vm, make sure
to run java with the server vm for best performance by adding - server to the command line

Which is the correct place to put -server command line option ?

Kuido


(system) #3