Newbie: Logstash clean install -> 30% cpu?


(André van der Wiel) #1

Installed ES and Logstash but the logstash process consumes 30 % cpu !
I stopped Logstash and cpu returns to normal use.
Did a reboot, cpu again up to 30%. Now I can stop logstash but cpu stays
high. There are 2 jobs running: /usr/bin/java
-Djava.io.tmpdir=/var/lib/logstash etc. When I kill these jobs logstash
does a auto restart
I also cannot apt-get remove Logstash with normal apt-get remove.

  1. Why is the cpu so high when Logstash is doing nothing?
  2. Why can't stop the process(es) or remove Logstash?
  3. in logfile: "Error: No config files found: /etc/logstash/conf.d/*\
  4. What am I doeing wrong?

Installprocess on Ubuntu 14.04:
sudo su
wget -O - http://packages.elasticsearch.org/GPG-KEY-elasticsearch | apt-key
add -

vi /etc/apt/sources.list
deb http://packages.elasticsearch.org/elasticsearch/1.1/debian stable main
deb http://packages.elasticsearch.org/logstash/1.4/debian stable main

apt-get update
apt-get upgrade
apt-get install elasticsearch
apt-get install logstash
apt-get install openjdk-7-jre-headless
update-rc.d elasticsearch defaults 95 10
sudo /etc/init.d/elasticsearch start
sudo /etc/init.d/logstash start

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c897de82-e069-4425-a089-1f415e2bac23%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

You should really ask that over on the Logstash list :slight_smile:
https://groups.google.com/forum/#!forum/logstash-users

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 29 June 2014 09:03, André van der Wiel awiel@scapeler.com wrote:

Installed ES and Logstash but the logstash process consumes 30 % cpu !
I stopped Logstash and cpu returns to normal use.
Did a reboot, cpu again up to 30%. Now I can stop logstash but cpu stays
high. There are 2 jobs running: /usr/bin/java
-Djava.io.tmpdir=/var/lib/logstash etc. When I kill these jobs logstash
does a auto restart
I also cannot apt-get remove Logstash with normal apt-get remove.

  1. Why is the cpu so high when Logstash is doing nothing?
  2. Why can't stop the process(es) or remove Logstash?
  3. in logfile: "Error: No config files found: /etc/logstash/conf.d/*\
  4. What am I doeing wrong?

Installprocess on Ubuntu 14.04:
sudo su
wget -O - http://packages.elasticsearch.org/GPG-KEY-elasticsearch |
apt-key add -

vi /etc/apt/sources.list
deb http://packages.elasticsearch.org/elasticsearch/1.1/debian stable main
deb http://packages.elasticsearch.org/logstash/1.4/debian stable main

apt-get update
apt-get upgrade
apt-get install elasticsearch
apt-get install logstash
apt-get install openjdk-7-jre-headless
update-rc.d elasticsearch defaults 95 10
sudo /etc/init.d/elasticsearch start
sudo /etc/init.d/logstash start

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c897de82-e069-4425-a089-1f415e2bac23%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c897de82-e069-4425-a089-1f415e2bac23%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624a3%2BH0gB7A48jfBbQMXa0-m%3DqW4Z5QgON%3De8Ah0w1zHHg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(André van der Wiel) #3

Thanks, post moved to logstash-users forum.
André

Op zondag 29 juni 2014 01:41:06 UTC+2 schreef Mark Walkom:

You should really ask that over on the Logstash list :slight_smile:
https://groups.google.com/forum/#!forum/logstash-users

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 29 June 2014 09:03, André van der Wiel <aw...@scapeler.com
<javascript:>> wrote:

Installed ES and Logstash but the logstash process consumes 30 % cpu !
I stopped Logstash and cpu returns to normal use.
Did a reboot, cpu again up to 30%. Now I can stop logstash but cpu stays
high. There are 2 jobs running: /usr/bin/java
-Djava.io.tmpdir=/var/lib/logstash etc. When I kill these jobs logstash
does a auto restart
I also cannot apt-get remove Logstash with normal apt-get remove.

  1. Why is the cpu so high when Logstash is doing nothing?
  2. Why can't stop the process(es) or remove Logstash?
  3. in logfile: "Error: No config files found: /etc/logstash/conf.d/*\
  4. What am I doeing wrong?

Installprocess on Ubuntu 14.04:
sudo su
wget -O - http://packages.elasticsearch.org/GPG-KEY-elasticsearch |
apt-key add -

vi /etc/apt/sources.list
deb http://packages.elasticsearch.org/elasticsearch/1.1/debian stable
main
deb http://packages.elasticsearch.org/logstash/1.4/debian stable main

apt-get update
apt-get upgrade
apt-get install elasticsearch
apt-get install logstash
apt-get install openjdk-7-jre-headless
update-rc.d elasticsearch defaults 95 10
sudo /etc/init.d/elasticsearch start
sudo /etc/init.d/logstash start

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c897de82-e069-4425-a089-1f415e2bac23%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c897de82-e069-4425-a089-1f415e2bac23%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bfee3628-a93f-43d3-8e40-459a24ebc6a3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4