No handler found for uri when creating a mapping


(Abhishek Mukherjee) #1

Hi,

I am following the ES Definitive guide. I am trying to create a mapping for
an index and type as follows.

curl -XPUT '192.168.1.103:9200/nxtxnlogs/transaction/' -d '
"mappings" : {
"default" : {
"properties" : {
"txn_id" : { "type" : "long" },
"logged_at" : { "type" : "string" },
"key_name" : { "type" : "string" },
"des" : {"type" : "string", "index" : "not_analyzed" },
"params" : { "type" : "string"}
}
}
}
}
';

But I get this error.

No handler found for uri [/nxtxnlogs/transaction/] and method [PUT].

Also how do I create an empty index.

I apologise if the questions are basic. But I can't find it in the
documentation.

Regards
Abhishek

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8e77e1e5-d8dd-40e0-a290-8137989bda44%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #2

An index can be comprised of multiple types, so the type is not needed in
the URL.

Try simply 192.168.1.103:9200/nxtxnlogs

Cheers,

Ivan

On Tue, Jun 17, 2014 at 1:14 AM, Abhishek Mukherjee 4271693@gmail.com
wrote:

Hi,

I am following the ES Definitive guide. I am trying to create a mapping
for an index and type as follows.

curl -XPUT '192.168.1.103:9200/nxtxnlogs/transaction/' -d '
"mappings" : {
"default" : {
"properties" : {
"txn_id" : { "type" : "long" },
"logged_at" : { "type" : "string" },
"key_name" : { "type" : "string" },
"des" : {"type" : "string", "index" : "not_analyzed" },
"params" : { "type" : "string"}
}
}
}
}
';

But I get this error.

No handler found for uri [/nxtxnlogs/transaction/] and method [PUT].

Also how do I create an empty index.

I apologise if the questions are basic. But I can't find it in the
documentation.

Regards
Abhishek

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8e77e1e5-d8dd-40e0-a290-8137989bda44%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8e77e1e5-d8dd-40e0-a290-8137989bda44%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBSZdUCUtY_%2BFnaDyUueFHfvWkA6m4eNOHwJhJ3S7eO%2BA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3