No Hosts Monitor Id or Url in Uptime

Hello Team,

We have successfully setup our Elastic Cluster - 7.17.5 with log-stash and search-guard.
We have enrolled ~530 nodes in our elastic cluster.

We tried to enable the HeartBeat to monitor/check the uptime of the nodes and more precisely to check the TLS cert expiration but with no success. The basic configuration we found in the Elasticsearch documentation also results in No Hosts Monitor Id or Url in Uptime.

However, we do see the data in the Observability in Kibana Discover (screenshot attached)

But nothing in the Uptime monitors(screenshot attached)

Configuration is default like available in the elastic documentation but I can share if needed.

We have seen that this issue persisted in version 7.6 of ELK.

Could you please help us with this? Thanks,

Best Regards,
LCSB Sysadmins

This is probably mapping related, when you use logstash you have to setup mappings with a direct connection to ES via /heartbeat setup

If it's the latter I'd highly recommend using a direct connection, Logstash doesn't add much for heartbeat use cases.

You may need to delete any indices that were created and the associated templates.

I'd also recommend reading Uptime and synthetic monitoring | Observability Guide [8.4] | Elastic , for our newer workflows with 8.x using fleet and agent.

I'd also recommend upgrading to Elastic 8.x generally

1 Like

Thanks Andrew! We mapped the direct connection to ES and it worked.

For users having similar issue -
To remind, we use version 7.17.5
We deleted the indices firstly, install heartbeat-elastic, configure the basic heartbeat.yml run the setup command, start the service
The heartbeat.yml included with other config the following -

  path: "/etc/heartbeat/monitors.d/*.yml"
  reload.enabled: true
  reload.period: 1s

And if you are using Searchguard like us, make sure the user you are using has correct(and limited) permissions in sg_roles.yml and the hash in sg_tenants.yml is correct

You have to restart the service heartbeat-elastic after each change.

Best Regards,

1 Like

I made an error, the file for correct hash should be sg_internal_users.yml

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.