No recovered [0] indices into cluster_state

Can anyone help: This is a prod environment and fresh install. No issue in Dev env its totally working

Es version:
"name" : "cnfdoqprels01",
"cluster_name" : "bitbucketES",
"cluster_uuid" : "gdT4F-bnS0ifFam9wSOWEQ",
"version" : {
"number" : "7.16.3",
"build_flavor" : "default",
"build_type" : "rpm",
"build_hash" : "4e6e4eab2297e949ec994e688dad46290d018022",
"build_date" : "2022-01-06T23:43:02.825887787Z",
"build_snapshot" : false,
"lucene_version" : "8.10.1",
"minimum_wire_compatibility_version" : "6.8.0",
"minimum_index_compatibility_version" : "6.0.0-beta1"
"tagline" : "You Know, for Search"

When I run
curl -u bitbucket:xxxxxxx http://localhost:9200/_cat/indices
-- no results

ES elasticsearch.yml: bitbucketES cnfdoqprels01 /app/elasticsearch/data
path.logs: /app/elasticsearch/logs
http.port: 9200
discovery.seed_hosts: ["", ""]
cluster.initial_master_nodes: ["cnfdoqprels01"]
action.auto_create_index: .monitoring*,.watches,.triggered_watches,.watcher-history*,.ml*
http.type: buckler
transport.type: buckler
ingest.geoip.downloader.enabled: false

Here is the log:
[2022-06-28T09:49:30,747][INFO ][o.e.x.d.l.DeprecationIndexingComponent] [cnfdoqprels01] deprecation component started
[2022-06-28T09:49:30,871][INFO ][o.e.t.TransportService ] [cnfdoqprels01] publish_address {}, bound_addresses {[::]:9300}
[2022-06-28T09:49:31,090][INFO ][o.e.b.BootstrapChecks ] [cnfdoqprels01] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2022-06-28T09:49:31,092][INFO ][o.e.c.c.Coordinator ] [cnfdoqprels01] cluster UUID [gdT4F-bnS0ifFam9wSOWEQ]
[2022-06-28T09:49:31,208][INFO ][o.e.c.s.MasterService ] [cnfdoqprels01] elected-as-master ([1] nodes joined)[{cnfdoqprels01}{mXZ-32sgST6jmCk3rSu06Q}{_khLAqR9Qee5KgrfMSrJpg}{}{}{cdfhilmrstw} elect leader, BECOME_MASTER_TASK, FINISH_ELECTION], term: 8, version: 57, delta: master node changed {previous , current [{cnfdoqprels01}{mXZ-32sgST6jmCk3rSu06Q}{_khLAqR9Qee5KgrfMSrJpg}{}{}{cdfhilmrstw}]}
[2022-06-28T09:49:31,274][INFO ][o.e.c.s.ClusterApplierService] [cnfdoqprels01] master node changed {previous , current [{cnfdoqprels01}{mXZ-32sgST6jmCk3rSu06Q}{_khLAqR9Qee5KgrfMSrJpg}{}{}{cdfhilmrstw}]}, term: 8, version: 57, reason: Publication{term=8, version=57}
[2022-06-28T09:49:31,332][INFO ][o.e.h.AbstractHttpServerTransport] [cnfdoqprels01] publish_address {}, bound_addresses {[::]:9200}
[2022-06-28T09:49:31,332][INFO ][o.e.n.Node ] [cnfdoqprels01] started
[2022-06-28T09:49:31,903][INFO ][o.e.l.LicenseService ] [cnfdoqprels01] license [a333054f-7d5c-41f9-8f66-3989a60e2169] mode [basic] - valid
[2022-06-28T09:49:31,912][INFO ][o.e.g.GatewayService ] [cnfdoqprels01] recovered [0] indices into cluster_state

Welcome to our community! :smiley:
Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you.

It's not clear what you are expecting here, but Elasticsearch is saying it doesn't have any indices to recover.

Issue fixed. I run reindex command
curl -u -X POST -H 'Content-Type: application/json' -H 'Accept: application/json' http://:7990/rest/indexing/latest/sync

7 Indices are now recovered


That's not a request to an Elasticsearch endpoint, so it's not clear why that's fixed it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.