NoShardAvailableActionException Error on ElasticSearch on Docker

I set up basic security for the Elastic Stack plus secured HTTPS traffic recently and i encrypted all communication between the elastic nodes even though i use only one node.
The thins is now kibana will have this error message Unable to retrieve version information from Elasticsearch nodes.. Take in mind that elastic and kibana are running on containers but are able to reach each other. They were working perfectly before i tried to set up the advanced security.

So i checked the logs and elastic throws and error that states: org.elasticsearch.action.NoShardAvailableActionException: No shard available for [org.elasticsearch.action.fieldcaps.FieldCapabilitiesIndexRequest/unset]

Here are the full elastic logs

So i'm new here and i don't know what is casing this.... but yeah kibana cannot reach now elastic.
Please help.

Thanks in advance

You can ignore that one, it's not relevant.

This is though;

{"type": "server", "timestamp": "2021-07-25T09:55:16,445Z", "level": "WARN", "component": "o.e.x.s.t.n.SecurityNetty4HttpServerTransport", "": "docker-cluster", "": "ab3126eeaab4", "message": "received plaintext http traffic on an https channel, closing connection Netty4HttpChannel{localAddress=/, remoteAddress=/}", "cluster.uuid": "RYzBZKX6QBGHfy-OE1eX3g", "": "2lN-JR6HR_S8AQ_Qnsh8sw"  }

Did you configure Kibana to use HTTPS to talk to Elasticsearch?

Yes. I think this is my test i was making with Curl command. I tried to hit https without providing a crt.

So the NoShardAvailableAction is not something that i should fix right?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.