Not able to authenticate Kibana via jwt

Hi,

we have requirement from our application on pivoting to Kibana, we should directly land to dashboard tab without any login screen. To achieve this we are using jwt kibana authentication.
We have added the below nginx settings:

location ~ ^/(analytics|app|plugins|built_assets|bundles|ui|translations|api/console|api/interpreter|api/v1|api/saved_objects|node_modules) {*
rewrite ^/analytics(.*) /$1 break;
proxy_pass https://[host ip]:5601;
** }**

from our code we are passing '/app/kibana' via nginx it will redirect to kibana directly.

We are able to reach kibana but data is not loading. We are getting the below error.

But if i will pass the port( 5601) in url it works fine. Data is loaded successfully.
Can we get some help here?

this seems to be because of the CSP rules, where the IP used by the user, is different from the one used by Kibana.

Try setting the server.host configuration in the config/kibana.yml (https://www.elastic.co/guide/en/kibana/current/settings.html) to the actual IP or domain that users use to visit the application.

I tried adding this property in kibana.yml. But now i am not able to pivot from my application to kibana (my application and kibana is at same ip)

Is there a way to disable csrf token in kibana?