Not able to change to

I have elasticsearch running on a vm. I am trying to access it outside the vm. when i tired to assign the to either the vm's ip or elasticsearch service doesn't start. any tips?

I see the issue here, once i change the, dev config automatically changes to production. how can i put it back to dev settings?

If this is for testing purpose and running as a single node, you can set discovery.type: single-node in elasticsearch.yml file while binding to a non-loopback interface. See details at

Please note this is only useful for developement and testing purposes and not suitable for production.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.