Not able to create index in elasticsearch-0.90.5 with lengthy names


(Hanish Bansal) #1

Hi All,

We are trying to create indices with below name format

testindex_16161_1396381784242

Till elasticsearch-0.90.2, we are able to create indices with this
naming convention.

When i try to create to index with same name as above mentioned in
elasticsearch-0.90.5, i get below

exception:

[2014-04-01 18:17:41,683][DEBUG][action.admin.indices.create] [node0]
[testindex_16161_1396375678203] failed to create
java.lang.NumberFormatException: For input string: "1396375678203"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
at java.lang.Integer.parseInt(Integer.java:461)
at java.lang.Integer.valueOf(Integer.java:554)
at org.elasticsearch.cluster.routing.RoutingIndexSorter$ShardComparator.compare(RoutingIndexSorter.java:89)
at org.elasticsearch.cluster.routing.RoutingIndexSorter$ShardComparator.compare(RoutingIndexSorter.java:82)
at org.apache.lucene.util.CollectionUtil$ListIntroSorter.compare(CollectionUtil.java:64)
at org.apache.lucene.util.Sorter.insertionSort(Sorter.java:169)
at org.apache.lucene.util.IntroSorter.quicksort(IntroSorter.java:46)
at org.apache.lucene.util.IntroSorter.sort(IntroSorter.java:41)
at org.apache.lucene.util.CollectionUtil.introSort(CollectionUtil.java:137)
at org.elasticsearch.cluster.routing.RoutingIndexSorter.getSortedList(RoutingIndexSorter.java:57)
at org.elasticsearch.cluster.routing.RoutingNodes.unassigned(RoutingNodes.java:232)
at org.elasticsearch.cluster.routing.allocation.AllocationService.reroute(AllocationService.java:154)
at org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$2.execute(MetaDataCreateIndexService.java:359)
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:299)
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:662)

If i remove some digits to short the index name for example

testindex_16161_1396381 and then try to create, in that case i am
able to create index successfully.

Is there any limit on index name in elasticsearch-0.90.5, if not how
can i resolve this issue?

--
Thanks & Regards
Hanish Bansal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAB0WE8YGhUumZs209zZFvAa5tk2m0HYoLQeXyLdvL6Gc_8nHGw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Binh Ly-2) #2

Can you show how you create the index? I just tried this on 0.90.5 and it
seemed to work for me:

$ curl -XPUT localhost:9200/testindex_16161_1396381784242
{"ok":true,"acknowledged":true}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9c393e9c-975a-466d-8086-6d8068fd002e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Hanish Bansal) #3

Hi Binh,

I was also using same call as you mentioned. I found the issue, actually
few months back i applied a custom plugin in my elastic-search and just
forgot about that. Now i tried with fresh elastic-search and its working
fine.

Thanks for your response !!

On Tue, Apr 1, 2014 at 9:05 PM, Binh Ly binhly_es@yahoo.com wrote:

Can you show how you create the index? I just tried this on 0.90.5 and it
seemed to work for me:

$ curl -XPUT localhost:9200/testindex_16161_1396381784242
{"ok":true,"acknowledged":true}

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9c393e9c-975a-466d-8086-6d8068fd002e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/9c393e9c-975a-466d-8086-6d8068fd002e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Thanks & Regards
Hanish Bansal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAB0WE8YLJcuQNBN52xCbs%3DcAkDm3YYdDPo%2BeK%2BzuUrTuPiuAUw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4