Not able to create INDEX in ES


#1

Hi All,

I am given below twitter input and output code in my logstash-config file.

input {
twitter {
# add your data
consumer_key => ""
consumer_secret => ""
oauth_token => ""
oauth_token_secret => ""
full_tweet => true
keywords => ["XXXX"]
}
}

output {
elasticsearch_http {
host => "localhost"
index => "twitter24"
index_type => "tweet1"
}
}

Step2:
logstash agent --debug -f logstash-simple.conf

I run above command in logstash

It run properly without any error.

Step3:
curl localhost:9200/_cat/indices?v

I run this command in CURL
But it's not showing any index which i given in twitter output config file.

Please help me with this issue.

Thanks,
Dan.


(Magnus B├Ąck) #2

logstash agent --debug -f logstash-simple.conf

I run above command in logstash

It run properly without any error.

What does it say? Specifically regarding the Elasticsearch interactions.

Please disable the elasticsearch_http output (which is deprecated in favor of elasticsearch with protocol => http) for now and make sure you get the data you expect with e.g. the stdout output so that we narrow things down to being a problem between Logstash and ES.


(system) #3