Not able to create role mapping in kibana

I have assigned one user as superuser and I am trying to search for role mapping under stack management in Kibana. But I am not able to see that. Even I tried to assign role using role mapping api. Still not able to login with role mapping.

What errors are you seeing ? On Elasticsearch master, have you added it to role mapping.yml . You cannot simply edit the file on the master node, it needs to exist on every node that can perform authentication (which is most clusters is every node). My guess is that your elected master node doesn't have the realms configured.

More documentation : Role mappings | Kibana Guide [master] | Elastic

copying @jportner for more insights

I am seeing this error
Realms [active_directory] were skipped because they are not permitted on the current license

That's pretty self explanatory, you can't use any LDAP type role mapping without a higher license.

Line LDAP, PKI3, Active Directory authentication

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.