Not able to install elasticsearch


(R H) #1

I'm trying to install elasticsearch following the instructions on this page:
https://www.elastic.co/downloads/elasticsearch

I downloaded elasticsearch-6.3.1. Added lib directory to my system path:C:\ElasticSearch\elasticsearch-6.3.1\lib

But when I run the bin\elasticsearch.bat, I get following error:
"Error: Could not find or load main class C:\ElasticSearch\elasticsearch-6.3.1\lib\elasticsearch-cli-6.3.1.jar"

The elasticsearch-cli-6.3.1.jar is in the lib directory. I have java 8 installed.
C:\ElasticSearch\elasticsearch-6.3.1>java -version
java version "1.8.0_171"
Java(TM) SE Runtime Environment (build 1.8.0_171-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.171-b11, mixed mode)

I've been struggling with this error for few days now. Pleas let me know how I can get pass this so that I can start learning ElasticSearch.

TIA


(Thomas Dasch) #2

If you're using Windows, have you tried using the MSI, it's the easiest way to get ES working on Windows. If you want to use the zip, follow the instructions in this doc.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.