Not able to install the logstash-input-jdbc 2.0.5 plugin


(kpc) #1

Hi !
I am not able to install the logstash-input-jdbc2.0.5 plugin from https://rubygems.org/gems/logstash-input-jdbc/versions/2.0.5. I tried mentioning 'gem 'logstash-input-jdbc', '~> 2.0', '>= 2.0.5' entry inside gemfile as well mentioned seperate dependencies one after another but it always fails for logstash-core dependency. Even installing seperate gem for logstash-core fails for every version. Other dependencies of logstash-input-jdbc2.0.5 plugin get fetched properly; only the issue about logstash-core gem. My gemfile has appropriate source in it i.e. 'source 'https://rubygems.org'.
Please help.

c:\DevKit>bundle install
Fetching gem metadata from https://rubygems.org/.........
Fetching version metadata from https://rubygems.org/...
Fetching dependency metadata from https://rubygems.org/..
Resolving dependencies...
Bundler could not find compatible versions for gem "logstash-core":
In Gemfile:
logstash-input-jdbc (= 2.0.5) x64-mingw32 depends on
logstash-core (< 3.0.0, >= 2.0.0.beta2) x64-mingw32
Could not find gem 'logstash-core (< 3.0.0, >= 2.0.0.beta2) x64-mingw32', which
is required by gem 'logstash-input-jdbc (= 2.0.5) x64-mingw32', in any of the
sources.

I have logstash 1.5.2 and my Linux VM cannot see internet hence I am installed logstash at local Windows 7 machine and I do have a plan to install logstash-input-jdbc2.0.5 at local logstash and then move it to my linux VM.

Appreciate any help.


(system) #2