Not able to send data to remote host


(Prateek Kshtriya) #1

Hi All,

I am not able to post data to elastic-search remote host .
Please suggest if there is any specific configuration required to be done to post data from metric-beat to different Elastic-search host.

Below error could be seen at metric-beat log-

2017-07-04T07:43:14Z ERR Connecting error publishing events (retrying): Get http://machinename:9200: dial tcp ip:9200: connectex: No connection could be made because the target machine actively refused it.

Regards,
Prateek


(Prateek Kshtriya) #2

Please suggest if I am missing anything.

Regards,
Prateek


(Andrew Kroh) #3

This sounds like a connectivity issue. Are you have to access the same address (http://machinename:9200) from a web broswer on the metricbeat host?


(Prateek Kshtriya) #4

Hi Andrew ,

I added network.host: 0.0.0.0 in elasticsearch.yml ,worked for me.

Regards,
Prateek


(Eric Yeh) #5

I'd been messing with iptables, firewall, and other network stuff, and this is the way to make it work. I would love to hear what is the reason behind this.

Thank you!


(Prateek Kshtriya) #6

I came up with the configuration as 0.0.0.0 as it is default route which leads to "the rest of" the internet instead of somewhere on the local network .
And as suggested from Andrew it seemed to be a network issue ,post which I tried to access the elasticsearch from different machine which failed.
Changing the configuration to 0.0.0.0 made it accessible.

Regards,
Prateek


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.