Not whitelisted in reindex.remote.whitelist

hi all ..
please help me with my strange issue ;

I want to reindex my old data from 2.3 cluster to 6.0
I tried 2 ways :

  1. with reindex.remote.whitelist ::
    I put my remote host in yaml :
    reindex.remote.whitelist: ''

u see it in _cluster/settings?pretty&include_defaults :

"reindex" : { "remote" : { "whitelist" : [ "" ] } },

but wen I try :

POST _reindex
"source": {
"remote": {
"host": "",
"username": "admin",
"password": "ssdsdwD"
"index": "reind_v4"

"dest": {
"index": "reind_v4"

I always get :

"type": "illegal_argument_exception",
"reason": "[] not whitelisted in reindex.remote.whitelist"

  1. the second way is via snapshot restore
    I tried :
PUT _snapshot/prod_bak
  "type": "s3",
  "settings": {
    "bucket": "elastic-bucket"

but when I check:

GET /_snapshot/prod_bak/_all

I got an empty array of snapshots :

  "snapshots": []

and when I do it with command line (aws s3 ls elastic-bucket) , I can see all my old snapshots :

what should I do that restore work??

1 Like

Please try to format properly your posts.

Did you restart the nodes after you added the reindex.remote.whitelist?

In case you did not read it, here is the documentation for this:

Hi David.. Thank you for reply..
yes... I restart node after added reindex.remote.whitelist on .yml file...
but anyway got

"type": "illegal_argument_exception",
"reason": "[[](] not whitelisted in 


Did you do that on all nodes?


Hmmm. That's weird.

Could you share the exact elasticsearch.yml file you have and the exact reindex request you sent? You can send it via PM if you don't want to share that in public.

cc @nik9000 in case it rings a bell...

thank you..
send you via PM

Copying here my private answer in case someone else gets the same:

In the config file, there is: false

reindex.remote.whitelist: 'xxxx:9200'

The indentation is wrong and I suspect this is causing some troubles.
Also I found some duplicated entries like: IP
network.publish_host: NAME IP
network.publish_host: NAME
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.