Elastic.co new cluster: set reindex.remote.whitelist


(Arun) #1

I am trying to upgrade from ES 2.4 to 6.2 using the "reindex from remote" approach. I am using elastic.co hosted service for the existing 2.4 cluster. I am trying to create a new 6.2 cluster, also on elastic.co. If I set reindex.remote.whitelist in user settings when creating the new cluster using the UI, it says "Illegal User Settings". How do I proceed?


(David Pilato) #2

Please see https://www.elastic.co/cloud/as-a-service/support on how to raise a support ticket for Elastic Cloud :slight_smile:


(Arun) #3

Contacted elastic support and got the answer. I don't really need to set it, since the default setting (as mentioned here ) allows remote indexing from any .io or .com domain.

Also, I was setting it like this:
reindex.remote.whitelist 9279bc1b294df7e40fc07f9b7f9f683.us-west-2.aws.found.io:9243
but taking hint from the guide page, the correct setting is probably like this:
reindex.remote.whitelist ["9279bc1b294df7e40fc07f9b7f9f683.us-west-2.aws.found.io:9243"]


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.