o.e.b.Bootstrap

[2020-09-29T15:25:43,752][ERROR][o.e.b.Bootstrap ] [VDCGraylogNode02] Exception
java.lang.IllegalArgumentException: node settings must not contain any index level settings
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:143) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.node.Node.(Node.java:370) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.node.Node.(Node.java:266) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:227) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) [elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) [elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) [elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) [elasticsearch-cli-7.8.1.jar:7.8.1]
at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) [elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.8.1.jar:7.8.1]
[2020-09-29T15:25:43,757][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [VDCGraylogNode02] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: node settings must not contain any index level settings
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:174) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) ~[elasticsearch-cli-7.8.1.jar:7.8.1]
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.8.1.jar:7.8.1]
Caused by: java.lang.IllegalArgumentException: node settings must not contain any index level settings
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:143) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.node.Node.(Node.java:370) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.node.Node.(Node.java:266) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:227) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) ~[elasticsearch-7.8.1.jar:7.8.1]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.8.1.jar:7.8.1]

I am unable to start the ES service can any one help :frowning:

node settings must not contain any index level settings

This means that your elasticsearch.yml file has wrong settings.

1 Like

David - I have pasted my yml file here, kindly correct me where i did mistake.

cluster.name: graylog
node.name: "Node01"
index.number_of_shards: 5
index.number_of_replicas: 1
path.data: /opt/data1/ESData/Index
path.logs: /opt/data1/ESData/logs
bootstrap.memory_lock: true
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.timeout: 3s
discovery.seed_hosts: ["10.46.XX.XX", "10.46.XX.XX"]
cluster.initial_master_nodes: ["Node01", "Node02"]
discovery.zen.ping.multicast.enabled: false
threadpool.bulk.queue_size: 1000
index.routing.allocation.disable_allocation: false

index.number_of_shards: 5
index.number_of_replicas: 1

These 2 settings belongs to Index Setting and should not be in elasticsearch.yml

Hope this helps!

1 Like

This setting is no longer used in Elasticsearch 7.x clusters.

This also does not belong in the config file.

I would also recommend reading the docs on resiliency as the settings indicate to me that you may have tried to achieve high availability with only 2 nodes, which is not possible.

2 Likes