Offline plugin installation?


(Craig Foote) #1

I have transferred the http_poller.gem file to my non-internet-connected intranet machine but when I run plugin install /pathToPlugin it times out trying to connect to the rubygems site. I saw some mention of --local flag but it comes back as an unrecognized option. I am running Logstash-1.5.3. Any help greatly appreciated.

Craig


(Mark Walkom) #2

That should definitely work, are you providing the full path?


(Steve Earl) #3

Hi Craig,

We're behind a firewall and I've been having the same problem when trying to do a local install of the Logstash-input-Lumberjack GEMS file into Logstash1.5.4.

See https://github.com/logstash-plugins/logstash-input-lumberjack/issues/46#issuecomment-138895158 for history of the issue.

I haven't found a workaround for this yet so would be interested if anyone here has any suggestions.

Cheers,
Steve


(Craig Foote) #4

The command I'm issuing is /opt/logstash/bin/plugin install --no-verify /tmp/logstash-input-http_poller-1.1.2.gem. The response I'm getting is ERROR: Installation Aborted, message: Could not fetch specs from https//rubygems.org. I tried with the --local flag as well but it came back ERROR: Unrecognized option '--local'.


(Craig Foote) #5

Ok this is interesting. Thinking the sequence of arguments might matter I ran /opt/logstash/bin/plugin install /tmp/logstash-input-http_poller-1.1.2.gem --local (with the --local at the end) and now I'm getting ERROR: Mixed source of plugins, you can't mix local .gem and remote gems.

Does anyone have an example of using --local to install local gems offline?


(Craig Foote) #6

So now my installation is broken :frowning:
Running anything including /opt/logstash/bin/logstash --version returns:
Bundler::VersionConflict: Bundler could not find compatible versions for gem logstash-mixin-http_client ... Could not find gem logstash-mixin-http_client (>=1.0.1) java, which is required by gem logstash-input-heep_poller(=1.1.2) java, in any of the sources. Start at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bunndler/resolved.rb:203 ...

That was logstash-1.5.3. I'm going to remove it and install 1.5.4 to see if the same thing happens.
Still waiting on someone to point to instructions of how to install a gem file offline...I can't believe I'm the first!

Craig


(Ankush Shankar) #7

Hi Craig

Did you have any luck with 1.5.4?
I am having the same problem. The plugin wants to connect to rubygems.org even when I give it the path to my gem.

Error Bundler::HTTPError, retrying 1/10
Could not fetch specs from https://rubygems.org/

(system) #8