OK to run Winlogbeat minor version older than Elasticsearch?


(James Watson) #1

I have a few hundred Windows servers indexing directly to elasticsearch (ie not through logstash) and everything was originally installed at 5.0.0.

I need to upgrade my elasticsearch cluster to 5.1.1 but I would rather not go through the trouble of upgrading all the servers unless it was necessary. I have a very vanilla implementation.

Is there a compelling need to upgrade winlogbeat agents in my case?


(Mark Walkom) #2

Not immediately, no. You definitely shouldn't leave big gaps though as there are improvements and bug fixes in each release :slight_smile:


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.