Open file handler limit problem on CentOS 6.9

Versions:

  • ElasticSearch 5.4.2
  • CentOS 6.9
  • JDK 1.8u131

On starting ElasticSearch, I ran into the following error message:

[2017-06-21T13:06:39,517][INFO ][o.e.t.TransportService ] [HOSTNAME_HERE] publish_address {192.168.1.30:9300}, bound_addresses {[::]:9300}
[2017-06-21T13:06:39,525][INFO ][o.e.b.BootstrapChecks ] [HOSTNAME_HERE] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
ERROR: [1] bootstrap checks failed
[1]: max file descriptors [65535] for elasticsearch process is too low, increase to at least [65536]
[2017-06-21T13:06:39,533][INFO ][o.e.n.Node ] [HOSTNAME_HERE] stopping ...
[2017-06-21T13:06:39,652][INFO ][o.e.n.Node ] [HOSTNAME_HERE] stopped
[2017-06-21T13:06:39,652][INFO ][o.e.n.Node ] [HOSTNAME_HERE] closing ...
[2017-06-21T13:06:39,668][INFO ][o.e.n.Node ] [HOSTNAME_HERE] closed

I tried following the instructions in the documentation for setting the max file descriptor. On restart, still didn't work.

I'm using the command sudo -u elasticsearch /opt/elasticsearch/bin/elasticsearch to start ElasticSearch as the appropriate user. It seems to be an OS issue, but I'm wondering if anyone ran into this with CentOS 6 and knows a work around that will get ElasticSearch running (like making it ignore that error?)

There was a typo in the docs (that has been fixed) where we accidentally said to set the value to 65535 instead of 65536. It looks like you need to increase the value in your limits.conf by 1 (we had an off-by-one error in the docs!)

See:

max file descriptors [65535] for elasticsearch process is too low, increase to at least [65536]

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.