Packetbeat installation fails on Windows

I am trying to install Packetbeat on a Windows server, but I am getting the following error:

Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to http://localhost:5601/api/status fails: fail to execute the HTTP GET request: Get http://localhost:5601/api/status: dial tcp connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.. Response: .

My configuration (packetbeat.yml) file has this information:

setup.dashboards.enabled: true

setup.kibana: [""]
host: [""]

hosts: [""]

My elasticsearch and Kibana are on the same host.

From the machine where I want to install packetbeat I can get to the host where Elasticsearch and Kibana are installed. I can ping and telnet.

Kibana and Elasticsearch version: 7.3.0
Packetbeat version: 7.3.1

Hi @thebeaoliveira,

Packetbeat is still trying to connect to, so it seems that it is not using the settings in the configuration file.

Looking at the file you pasted, it seems incorrectly formatted, could you paste the exact configuration you are using as preformatted text? (using the </> button in the toolbar)

Hi @jsoriano, it is like this

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
# setup.kibana: [""]

# Kibana Host
# Scheme and port can be left out and will be set to the default (http and 5601)
# In case you specify and additional path, the scheme is required: http://localhost:5601/path
# IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
host: [""]

#-------------------------- Elasticsearch output ------------------------------
# Array of hosts to connect to.
hosts: [""]

I think that some indentation is missing there, the configuration should be like this (removing comments for clarity):

    host: [""]

    hosts: [""]
1 Like

That was it!

Thanks for the help! :slight_smile:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.