Path.data does not work with my configuration in 18.2


(phobos182) #1

Upgraded to 18.2 from 17.7, and I'm trying to take advantage of the new comma deliminited path.data configuration. Upon startup, I receive this error.

http://pastebin.com/8CFActa7

Here is a copy of my current configuration.

http://pastebin.com/m46TCfSh

Any advice? I have not been able to find out why path.data is not working with the local gateway settings.


(phobos182) #2

Found out by doing a trace level debugging on "ENV" and a new ES_PATH was getting into the daemon launch. Fixed the environment issue, and the config file was respected.

Closed issue.


(Shay Banon) #3

What exactly was the problem? I did not understand... . Also, note that
there is a bug in handling multiple data locations in 0.18.2 (not
distributing the data properly):
https://github.com/elasticsearch/elasticsearch/issues/1436.

On Fri, Nov 11, 2011 at 11:07 PM, phobos182 phobos182@gmail.com wrote:

Found out by doing a trace level debugging on "ENV" and a new ES_PATH was
getting into the daemon launch. Fixed the environment issue, and the config
file was respected.

Closed issue.

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/path-data-does-not-work-with-my-configuration-in-18-2-tp3500902p3500947.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.


(phobos182) #4

I back ported that patch to 18.2 from the tag. Then ran gradle, and created a new RPM package. So I'm good to go on that data path issue. BTW: The gradle build is smooth, and painless. Only took me about 10 minutes to cherry-pick the commit from git, and repackage the whole application. Good work.

My issue was my init.d script. I have not checked it in a while, and it was setting a default "ES_WORK / ES_PATH" environment variable. This was overriding my configuration in elasticsearch.yml. Once I removed the environment variables from the init script, everything was good to go.

I used debug logging on env to find out what values it was setting. Then I traced it down to my init script.


(Shay Banon) #5

I see, thanks for the info! (wanted to double check if there si something
that can be simplified in elasticsearch).

On Mon, Nov 14, 2011 at 2:07 AM, phobos182 phobos182@gmail.com wrote:

I back ported that patch to 18.2 from the tag. Then ran gradle, and
created a
new RPM package. So I'm good to go on that data path issue. BTW: The gradle
build is smooth, and painless. Only took me about 10 minutes to cherry-pick
the commit from git, and repackage the whole application. Good work.

My issue was my init.d script. I have not checked it in a while, and it
was
setting a default "ES_WORK / ES_PATH" environment variable. This was
overriding my configuration in elasticsearch.yml. Once I removed the
environment variables from the init script, everything was good to go.

I used debug logging on env to find out what values it was setting. Then I
traced it down to my init script.

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/path-data-does-not-work-with-my-configuration-in-18-2-tp3500902p3505518.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.


(system) #6