Path.data not working


(gzion7) #1

I am trying to change the location where ES stores my data.
I am using AWS/EC2, it works in the default location but when I change the
path in the .yml file it fails to start.

I am also unable to enable debugging for my logs.
This is very frustrating.

Any ideas?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

If it does not start at all, your yml file is probably incorrect.

Check that you did not forget a space after path.data:

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2013 à 20:20, Gabriel Holder gavysdomain@gmail.com a écrit :

I am trying to change the location where ES stores my data.
I am using AWS/EC2, it works in the default location but when I change the path in the .yml file it fails to start.

I am also unable to enable debugging for my logs.
This is very frustrating.

Any ideas?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(gzion7) #3

Didn't work either.
I have it as:

path.data: /path/to/data

path.data:/opt

Tried with and without the space.

I did find this:

But I'm not sure how to change the init file.

On Wednesday, September 4, 2013 2:35:31 PM UTC-4, David Pilato wrote:

If it does not start at all, your yml file is probably incorrect.

Check that you did not forget a space after path.data:

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2013 à 20:20, Gabriel Holder <gavys...@gmail.com <javascript:>>
a écrit :

I am trying to change the location where ES stores my data.
I am using AWS/EC2, it works in the default location but when I change the
path in the .yml file it fails to start.

I am also unable to enable debugging for my logs.
This is very frustrating.

Any ideas?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #4

Did you try:

path.data: /opt

What can you see in logs?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2013 à 21:13, Gabriel Holder gavysdomain@gmail.com a écrit :

Didn't work either.
I have it as:

path.data: /path/to/data

path.data:/opt

Tried with and without the space.

I did find this:

But I'm not sure how to change the init file.

On Wednesday, September 4, 2013 2:35:31 PM UTC-4, David Pilato wrote:

If it does not start at all, your yml file is probably incorrect.

Check that you did not forget a space after path.data:

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2013 à 20:20, Gabriel Holder gavys...@gmail.com a écrit :

I am trying to change the location where ES stores my data.
I am using AWS/EC2, it works in the default location but when I change the path in the .yml file it fails to start.

I am also unable to enable debugging for my logs.
This is very frustrating.

Any ideas?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(gzion7) #5

Tried.
Logs don't generate anything.
I don't think I turned on logging correctly.
How can I do that?

On Wednesday, September 4, 2013 3:22:23 PM UTC-4, David Pilato wrote:

Did you try:

path.data: /opt

What can you see in logs?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2013 à 21:13, Gabriel Holder <gavys...@gmail.com <javascript:>>
a écrit :

Didn't work either.
I have it as:

path.data: /path/to/data

path.data:/opt

Tried with and without the space.

I did find this:
https://github.com/elasticsearch/elasticsearch/issues/1765

But I'm not sure how to change the init file.

On Wednesday, September 4, 2013 2:35:31 PM UTC-4, David Pilato wrote:

If it does not start at all, your yml file is probably incorrect.

Check that you did not forget a space after path.data:

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2013 à 20:20, Gabriel Holder gavys...@gmail.com a écrit :

I am trying to change the location where ES stores my data.
I am using AWS/EC2, it works in the default location but when I change
the path in the .yml file it fails to start.

I am also unable to enable debugging for my logs.
This is very frustrating.

Any ideas?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(gzion7) #6

Any help would be great.
This thing is kicking my ass.

On Wednesday, September 4, 2013 3:30:50 PM UTC-4, Gabriel Holder wrote:

Tried.
Logs don't generate anything.
I don't think I turned on logging correctly.
How can I do that?

On Wednesday, September 4, 2013 3:22:23 PM UTC-4, David Pilato wrote:

Did you try:

path.data: /opt

What can you see in logs?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2013 à 21:13, Gabriel Holder gavys...@gmail.com a écrit :

Didn't work either.
I have it as:

path.data: /path/to/data

path.data:/opt

Tried with and without the space.

I did find this:
https://github.com/elasticsearch/elasticsearch/issues/1765

But I'm not sure how to change the init file.

On Wednesday, September 4, 2013 2:35:31 PM UTC-4, David Pilato wrote:

If it does not start at all, your yml file is probably incorrect.

Check that you did not forget a space after path.data:

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2013 à 20:20, Gabriel Holder gavys...@gmail.com a écrit :

I am trying to change the location where ES stores my data.
I am using AWS/EC2, it works in the default location but when I change
the path in the .yml file it fails to start.

I am also unable to enable debugging for my logs.
This is very frustrating.

Any ideas?

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brian Yoder) #7

You also need to tell ElasticSearch where to find the config file if you
move it. For instance, start ElasticSearch with the following command-line
option:

*-Des.path.conf=*path-to-config-file

Brian

On Thursday, September 5, 2013 12:49:08 PM UTC-4, Gabriel Holder wrote:

Any help would be great.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #8