Path.Data partition is going Read-Only periodically


I have a deployed cluster V7.16.1 on Linux platform (ubuntu lts), but what is happening is that every time one of the partitions mapped to is becoming Read-Only until I run file-system check (fsck) on the disk and repair the errors than mount it again.
Is this a common issue ??

Thank You

No, it's not common. It'd usually indicate you have storage issues, outside of Elasticsearch's control.

How do you know it's gone read only?
What to the Elasticsearch and OS logs show?

I found in logs something that indicates the inability to write, and when i test to create a file or a folder (mkdir/touch) the console return the read-only error: Read-only file system
and when i run fsck on the lvm i actually find errors.

It'd be good to share the exact errors you are seeing, especially from Elasticsearch.

I'm sorry I fixed the disk and restarted the node, I didn't save such infos. if it happens again I will try to share with you.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.