Plugin-descriptor.properties for Elastic Search Plugin JDBC-2.0.0.0 2.2.0


#1

Can anybody got lucky with JDBC-2.0.0.0 plug in descriptor file ?

I am using ES 2.2.0 and JDBC Importer 2.0.0.0 in a windows environment? Anyone has similar setup and successful in running this with connection to SQL Server 2012, please share some knowledge on set up and configuration?

2016-03-25 14:28:46 Commons Daemon procrun stderr initialized
Java HotSpot(TM) 64-Bit Server VM warning: Using the ParNew young collector with the Serial old collector is deprecated and will likely be removed in a future release
Exception in thread "main" xception: D:\IRIS_ELK\ElasticSearch\ES2.2\plugins\elasticsearch-jdbc-2.0.0.0\plugin-descriptor.properties
at sun.nio.fs.WindowsException.translateToIOException(Unknown Source)

Getting an error for missing JDBC-2.0.0.0


(Jörg Prante) #2

JDBC importer is not a plugin. Therefore, there is no plugin-descriptor.properties

Install it like described in the README instructions, it is a standalone application. For a windows environment, there are some hints from the community in the issues, since I have no time to test and validate the project under Windows.

In the project you can also find an example for setting up JDBC importer in docker. In the future there will be a dockerized build for convenience.


#3

I am trying to setup in window machine ( 7.0)
I did follow the same instructions as described in


But soon after I install the Plug in for this JDBC Importer ( 2.2.0), I could not start the Elastic Search as a windows service. It fails to start. If I remove that Plug in, I can start it.

So I started ES Service and then tried to unzip the elasticsearch-jdbc-2.2.0.0.zip file into plugin's directory and trie dto run the jdbc_sqlserver.ps1 file from bin/feeder directory, it does not work. nothing happens. No errors in the screen. but from logs directory, i get the following error.

java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [elasticsearch-jdbc-2.0.0.0]. Was the plugin built before 2.0?
at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:380)
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:128)
at org.elasticsearch.node.Node.(Node.java:146)
at org.elasticsearch.node.Node.(Node.java:128)
at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:145)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:285)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)

Tried to clean up and tried several times to reinstall and install, but NO luck.


(Jörg Prante) #4

The instructions are no longer valid because they pre-date Elasticsearch 2.x


#5

Thanks.

Can some one help/guide me to set up ELK on a Windows server and get data from SQL server frequently to Elastic Search and then to Kibana.

I need instructions to set up ELK on Windows server.


(Mark Walkom) #6

You can leverage the JDBC plugin in Logstash for this as well.


(system) #7