Plugin:elasticsearch Unable to connect to Elasticsearch at https://es-logging-poc-eag-cpsprod.int.thomsonreuters.com:9200


(Gj Sham) #1

My kibana is not able to connect to elasticsearch. Both have installed in same severs. My Elastic search is up,. I have using selfsigned Certificate for HTTPS. My kibana is also up but not able to connect to elastic search.

I did:
asadmin@c197dgt:~> curl -k https://es-logging-poc-eag-cpsprod.int.thomsonreuters.com:9200
{
"name" : "c197dgt-master-9200",
"cluster_name" : "es-logging-poc-eag",
"cluster_uuid" : "4qvRTKgCRTqIEhBWzB3TEw",
"version" : {
"number" : "2.4.2",
"build_hash" : "161c65a337d4b422ac0c805f284565cf2014bb84",
"build_timestamp" : "2016-11-17T11:51:03Z",
"build_snapshot" : false,
"lucene_version" : "5.5.2"
},
"tagline" : "You Know, for Search"
}

also:

this the error in app.out:

nections"}
{"type":"log","@timestamp":"2017-07-03T11:31:05+00:00","tags":["warning","elasticsearch"],"pid":44913,"message":"Unable to revive connection: https://es-logging-poc-eag-cpsprod.int.thomsonreuters.com:9200/"}
{"type":"log","@timestamp":"2017-07-03T11:31:05+00:00","tags":["warning","elasticsearch"],"pid":44913,"message":"No living connections"}
{"type":"log","@timestamp":"2017-07-03T11:31:08+00:00","tags":["warning","elasticsearch"],"pid":44913,"message":"Unable to revive connection: https://es-logging-poc-eag-cpsprod.int.thomsonreuters.com:9200/"}
{"type":"log","@timestamp":"2017-07-03T11:31:08+00:00","tags":["warning","elasticsearch"],"pid":44913,"message":"No living connections"}
{"type":"log","@timestamp":"2017-07-03T11:31:11+00:00","tags":["warning","elasticsearch"],"pid":44913,"message":"Unable to revive connection: https://es-logging-poc-eag-cpsprod.int.thomsonreuters.com:9200/"}
{"type":"log","@timestamp":"2017-07-03T11:31:11+00:00","tags":["warning","elasticsearch"],"pid":44913,"message":"No living connections"}
{"type":"log","@timestamp":"2017-07-03T11:31:13+00:00","tags":["warning","elasticsearch"],"pid":44913,"message":"Unable to revive connection: https://es-logging-poc-eag-cpsprod.int.thomsonreuters.com:9200/"}
{"type":"log","@timestamp":"2017-07-03T11:31:13+00:00","tags":["warning","elasticsearch"],"pid":44913,"message":"No living connections"}


(Mark Walkom) #2

You may want to redact those URLs :slight_smile:


(Gj Sham) #3

How do I do it, when I have used elasticsearch_url: http://trams-logstash-eag-preprod.int.thomsonreuters.com:9200, means If I am using http I am able to connect but with https it is not,

here is my kibana.xml setting:

elasticsearch_url: https://es-logging-poc-eag-cpsprod.int.thomsonreuters.com:9200
#elasticsearch_url: http://trams-logstash-eag-preprod.int.thomsonreuters.com:9200
server.ssl.cert: /appserver/security/kibana/cert.pem
server.ssl.key: /appserver/security/kibana/key.pem
deadTimeout: 60000


(Gj Sham) #4

this is resolved after passing elasticsearch.ssl.verify: false

and

basic user authentication to communicate with Elasticsearch.

kibana_elasticsearch_password: XXXXX

kibana_elasticsearch_username: XXXXXXXX


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.