Point In Time creation failure after upgrade

Hello, I need some help in an issue, I recently upgraded my Elasticsearch on local setup ( i.e downloaded 7.16.2 ). Now when I try to run a Point in Time API to retrieve the PIT id, on the Elasticsearch logs it gives me NPE saying that Point In Time is cannot be null, but as this is PIT creation call how can a PIT id be passed

> curl -X POST "localhost:9200/dummy_index/_pit?keep_alive=1m&pretty"

  "error" : {
    "root_cause" : [
        "type" : "null_pointer_exception",
        "reason" : "Point in time parameter must be not null"
    "type" : "null_pointer_exception",
    "reason" : "Point in time parameter must be not null"
  "status" : 500

Truncated Logs:

path: /dummy_index/_pit, params: {pretty=, index=dummy_index, keep_alive=1m}
java.lang.NullPointerException: Point in time parameter must be not null
	at java.util.Objects.requireNonNull(Objects.java:246) ~[?:?]
	at org.elasticsearch.action.search.OpenPointInTimeResponse.<init>(OpenPointInTimeResponse.java:38) ~[elasticsearch-7.16.2.jar:7.16.2]
	at org.elasticsearch.action.search.TransportOpenPointInTimeAction.lambda$doExecute$1(TransportOpenPointInTimeAction.java:112) ~[elasticsearch-7.16.2.jar:7.16.2]
	at org.elasticsearch.action.ActionListener$MappedActionListener.onResponse(ActionListener.java:95) [elasticsearch-7.16.2.jar:7.16.2]
	at org.elasticsearch.action.ActionListener$RunAfterActionListener.onResponse(ActionListener.java:341) [elasticsearch-7.16.2.jar:7.16.2]
	at org.elasticsearch.action.search.AbstractSearchAsyncAction.start(AbstractSearchAsyncAction.java:196) [elasticsearch-7.16.2.jar:7.16.2]
	at org.elasticsearch.action.search.TransportSearchAction.executeSearch(TransportSearchAction.java:1045) [elasticsearch-7.16.2.jar:7.16.2]
	at org.elasticsearch.action.search.TransportSearchAction.executeLocalSearch(TransportSearchAction.java:761) [elasticsearch-7.16.2.jar:7.16.2]



just tried the same locally on 7.16.2 and it worked. I created an index with a single document. Can you provide a full reproduction including index creation/mapping and the output of curl localhost:9200/ ? Is that a single node cluster? Any cross cluster search involved? Thanks a lot!


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.