Port settings not working?


(Jordan Sissel) #1

% bin/elasticsearch -f -Dhttp.port=14000 -Dtransport.tcp.port=14001 -
Dmemcached.port=14002
...
[2011-02-06 02:37:26,203][INFO ][transport ]
[Gargouille] bound_address {inet[/0:0:0:0:0:0:0:0:9300]},
publish_address {inet[/192.168.0.97:9300]}
...
[2011-02-06 02:37:29,762][INFO ][http ]
[Gargouille] bound_address {inet[/0:0:0:0:0:0:0:0:9200]},
publish_address {inet[/192.168.0.97:9200]}

% lsof -nPp 9033 | grep LISTEN
java 9033 jls 19u IPv6 4597460 0t0 TCP *:
9300 (LISTEN)
java 9033 jls 101u IPv6 4597545 0t0 TCP *:
9200 (LISTEN)

Same behavior in 0.14.4 and 0.13.1.

I need this so I can run unit tests that verify functionality against
multiple versions of elasticsearch, so having multiple versions of
elastic search clustering on the same ports makes for failing tests
due to expectations of isolation that are not valid.

Thoughts? Searching the list, I found a post saying that 0.7.1 added
support for these configuration values, but they appear to not work
today.

-Jordan


(Lukáš Vlček) #2

Hi,
Try adding "es." prefix to each setting, for example -Des.http.port=14000
Regards,
Lukas
Dne 6.2.2011 11:41 "Jordan Sissel" jls@semicomplete.com napsal(a):

% bin/elasticsearch -f -Dhttp.port=14000 -Dtransport.tcp.port=14001 -
Dmemcached.port=14002
...
[2011-02-06 02:37:26,203][INFO ][transport ]
[Gargouille] bound_address {inet[/0:0:0:0:0:0:0:0:9300]},
publish_address {inet[/192.168.0.97:9300]}
...
[2011-02-06 02:37:29,762][INFO ][http ]
[Gargouille] bound_address {inet[/0:0:0:0:0:0:0:0:9200]},
publish_address {inet[/192.168.0.97:9200]}

% lsof -nPp 9033 | grep LISTEN
java 9033 jls 19u IPv6 4597460 0t0 TCP *:
9300 (LISTEN)
java 9033 jls 101u IPv6 4597545 0t0 TCP *:
9200 (LISTEN)

Same behavior in 0.14.4 and 0.13.1.

I need this so I can run unit tests that verify functionality against
multiple versions of elasticsearch, so having multiple versions of
elastic search clustering on the same ports makes for failing tests
due to expectations of isolation that are not valid.

Thoughts? Searching the list, I found a post saying that 0.7.1 added
support for these configuration values, but they appear to not work
today.

-Jordan


(Jordan Sissel) #3

On Sun, Feb 6, 2011 at 3:17 AM, Lukáš Vlček lukas.vlcek@gmail.com wrote:

Hi,
Try adding "es." prefix to each setting, for example -Des.http.port=14000
Regards,
Lukas

Works, thanks!

-Jordan

Dne 6.2.2011 11:41 "Jordan Sissel" jls@semicomplete.com napsal(a):

% bin/elasticsearch -f -Dhttp.port=14000 -Dtransport.tcp.port=14001 -
Dmemcached.port=14002
...
[2011-02-06 02:37:26,203][INFO ][transport ]
[Gargouille] bound_address {inet[/0:0:0:0:0:0:0:0:9300]},
publish_address {inet[/192.168.0.97:9300]}
...
[2011-02-06 02:37:29,762][INFO ][http ]
[Gargouille] bound_address {inet[/0:0:0:0:0:0:0:0:9200]},
publish_address {inet[/192.168.0.97:9200]}

% lsof -nPp 9033 | grep LISTEN
java 9033 jls 19u IPv6 4597460 0t0 TCP *:
9300 (LISTEN)
java 9033 jls 101u IPv6 4597545 0t0 TCP *:
9200 (LISTEN)

Same behavior in 0.14.4 and 0.13.1.

I need this so I can run unit tests that verify functionality against
multiple versions of elasticsearch, so having multiple versions of
elastic search clustering on the same ports makes for failing tests
due to expectations of isolation that are not valid.

Thoughts? Searching the list, I found a post saying that 0.7.1 added
support for these configuration values, but they appear to not work
today.

-Jordan


(system) #4