Preserve_position_increments mapping flag of suggester not working

Hi all,

my suggestion mapping and my suggestion call is working in principle,
except the behaviour that should be enabled by the
preserve_position_increments: false flag.

Excerpt of the ES reference:
"preserve_position_increments Enables position increments, defaults to true.
If disabled and using stopwords analyzer, you could get a field starting
with The Beatles, if you suggest for b. Note: You could also achieve this
by indexing two inputs, Beatles and The Beatles, no need to change a simple
analyzer, if you are able to enrich your data."

my mapping:

                    "suggest": {
                         "type": "completion",
                        "index_analyzer": "standard",
                        "search_analyzer": "standard",
                        "payloads": true,
                        "preserve_separators": false,
                        "preserve_position_increments": false,
                        "max_input_length": 250

that is my call:

POST http://localhost:9200//_suggest {
"test-suggest" : {
"text" : "Adlon",
"completion" : {
"field" : "persons.3.perLanguage.deu.suggest"

the value of the field above is: Percy Adlon

it is working for the Text Percy, Per or PercyA

Any ideas what I am doing wrong? (ES version 1.3.2)

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit
For more options, visit