Problem creating a s3 repository with Elasticsearch


I have a bucket created in Amazon S3 and I dont get to create the repository withint it.
Through the awscli client I list and see all the folders inside the bucket so I thinks that the access_key and the secret_key works fine but when I try via curl command to create the repository in this bucket I obtain the next message:

curl -XPUT -H 'Content-Type: application/json' 'http://localhost:9200/_snapshot/my_repository' -d'
"type": "s3",
"settings": {
"bucket": "bucket_name",
"region": "us-east-1",
{"error":{"root_cause":[{"type":"repository_verification_exception","reason":"[my_repository] path [my_backups] is not accessible on master node"}],"type":"repository_verification_exception","reason":"[my_repository] path [my_backups] is not accessible on master node","caused_by":{"type":"i_o_exception","reason":"Unable to upload object my_backups/tests-Uy_1o3lfT7aEUCMjPFCzrw/master.dat-temp","caused_by":{"type":"amazon_s3_exception","reason":"amazon_s3_exception: Access Denied (Service: Amazon S3; Status Code: 403; Error Code: AccessDenied; Request ID: 1fb1cd8f4a428bd83b7e)"}}},"status":500}

I have tried to launch this command with the veryfy=false but it does not make sense if I have tried to create a snapshot after this.

Do you know if I need something else to create the s3 repository with Elasticsearch inside this buckets?

Thanks for all.
Best Regards

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.