Problem in the configuaration file of topbeat.yml


(preehana hareendran) #1

I am new to topbeat and had made the following changes in the configuration file of topbeat.

input:

In seconds, defines how often to read server statistics

period: 1

Regular expression to match the processes that are monitored

By default, all the processes are monitored

procs: [".*"]

Statistics to collect (all enabled by default)

stats:
# per system statistics, by default is true
system: true

# per process statistics, by default is true
proc: false

file system information, by default is true

filesystem: false

# cpu usage per core, by default is false
cpu_per_core: false

But ,still the proc values are pushed into elastic search..


(Magnus Bäck) #2

YAML is sensitive to indentation. Please format your configuration as code with the </> button so that we can see exactly what your configuration file looks like.


(preehana hareendran) #3
input:
  # In seconds, defines how often to read server statistics
  period: 10

  # Regular expression to match the processes that are monitored
  # By default, all the processes are monitored
  procs: [".*"]

  # Statistics to collect (all enabled by default)
  stats:
    # per system statistics, by default is true
    system: true

    # per process statistics, by default is true
    proc: false
   
   # file system information, by default is true
    filesystem: false

    # cpu usage per core, by default is false
    cpu_per_core: false

(Magnus Bäck) #4

According to https://www.elastic.co/guide/en/beats/topbeat/current/topbeat-configuration.html the option you want to disable is named process and not proc.


(Chirag) #5

Hi Magnus,

even after making process: false & proc: false and making sure indent is right.. the process information is still logged.
topbeat 1.1.2
Anyone help on this?

Regards,


(ruflin) #6

Can you share your config file with 3 ticks ` before and after so we can check if all is fine with the config file?


(Chirag) #7

Ruflin,

The problem solved.. it worked with topbeat version 1.2.2. topbeat version 1.1.2 had problems..
I am travelling and will share file laters.

Regards,


(system) #8