Problem to activate x-pack on Logstash

monitoring

(Alexandre Bunn) #1

Good afternoon

I have a logstash, version 5.6.8, instance running OK, after I've installed the x-pack and add the configurations line below, the daemon doesn't start and log the error below:

[2018-11-20T14:53:03,092][ERROR][logstash.pipeline ] A plugin had an unrecoverable error. Will restart this plugin.
Plugin: <LogStash::Inputs::Metrics collection_interval=>0, collection_timeout_interval=>600, id=>"0493c74c1dfcdce6bef350f101d3d465019bfd04-1", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_1c143796-f137-45d5-835e-bce6a8285f38", enable_metric=>true, charset=>"UTF-8">>
Error: must be greater than zero
Exception: ArgumentError
Stack: /usr/share/logstash/vendor/bundle/jruby/1.9/gems/concurrent-ruby-1.0.5-java/lib/concurrent/timer_task.rb:247:in `execution_interval='

  • X-pack Configuration lines in logstash.yml

root@pre-logstash01-mia:/etc/logstash# tail logstash.yml

Where to find custom plugins

path.plugins:

#Confs do X-pack
xpack.monitoring.enabled: true
xpack.monitoring.collection.interval: 60
xpack.monitoring.elasticsearch.url: "http://elasticserver:9200"
xpack.monitoring.elasticsearch.username: ''
xpack.monitoring.elasticsearch.password: ''

Thanks

Regards

Alexandre Bunn


(Thomas Falkenberg) #2

Had the same problem - you need to specifiy the unit, so "60s" in your case.
https://www.elastic.co/guide/en/elasticsearch/reference/current/monitoring-settings.html#monitoring-collection-settings

Cheers
Thomas


(Alexandre Bunn) #3

Thanks a lot, I've checked the logs in debug level but there weren't any evidence of an error.

Regards

Alexandre Bunn