Enabling X-pack monitoring for logstash

HI,

I recently started learning ELK . I am trying to setup monitoring X-pack on logstash but couldn't find the directory called plugins like in elastic search or kibana . Moreover , can I please know how to configure below settings in logstash . Should we need to configure them in logstash.yml ? because I created seperate logstash conf file.

xpack.monitoring.enabled: "true"

xpack.monitoring.elasticsearch.url: "http://xx.xx.xx.xx:9200"

xpack.monitoring.elasticsearch.username: "elastic"

xpack.monitoring.elasticsearch.password: "changeme"

Hi @kenny123

Assuming you have successfully installed x-pack for Logstash, you should put the x-pack monitoring configuration settings in your existing logstash.yml file.

Rob

Thank you for the reply. I downloaded the zipped x-pack file to logstash and unzipped it . I specified the parameters in logstash.yml but I am getting an below error

[2017-10-31T13:51:02,702][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"fb_apache", :directory=>"/root/logstash-sap/modules/fb_apache/configuration"}
[2017-10-31T13:51:02,713][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"netflow", :directory=>"/root/logstash-sap/modules/netflow/configuration"}
[2017-10-31T13:51:02,731][FATAL][logstash.runner          ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "xpack.monitoring.enabled" hasn't been registered>, :backtrace=>["/root/logstash-sap/logstash-core/lib/logstash/settings.rb:32:in `get_setting'", "/root/logstash-sap/logstash-core/lib/logstash/settings.rb:64:in `set_value'", "/root/logstash-sap/logstash-core/lib/logstash/settings.rb:83:in `merge'", "org/jruby/RubyHash.java:1342:in `each'", "/root/logstash-sap/logstash-core/lib/logstash/settings.rb:83:in `merge'", "/root/logstash-sap/logstash-core/lib/logstash/settings.rb:135:in `validate_all'", "/root/logstash-sap/logstash-core/lib/logstash/runner.rb:243:in `execute'", "/root/logstash-sap/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/root/logstash-sap/logstash-core/lib/logstash/runner.rb:204:in `run'", "/root/logstash-sap/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/root/logstash-sap/lib/bootstrap/environment.rb:71:in `(root)'"]}

Hi @kenny123

That sounds like x-pack hasn't been installed for Logstash - did you follow all of the the installation instructions - in particular the command to install the plugin by invoking either
bin/logstash-plugin install x-pack or
bin/logstash-plugin install file:///path/to/file/x-pack-5.6.3.zip if your logstash server does not have internet access.

2 Likes

Thank you very much. I didn't install it correctly .. After re-installation , it is working fine .

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.