X-Pack Logstash Settings issue


(MJay) #1

I have installed the X-Pack on logstash for monitoring. I don't see the logstash.yml file is being updated with additional xpack monitoring settings. Still I see the following settings when I run the logstash. Also the xpack monitoring settings which I have set in logstash.yml are not being picked up. In fact somehow none of the settings from logstash.yml are being considered.

From where the following settings were being picked up?

] xpack.monitoring.enabled: true
[2017-08-02T16:58:01,962][DEBUG][logstash.runner ] xpack.monitoring.elasticsearch.url: ["http://localhost:9200"]
[2017-08-02T16:58:01,962][DEBUG][logstash.runner ] xpack.monitoring.collection.interval: 10000000000
[2017-08-02T16:58:01,962][DEBUG][logstash.runner ] xpack.monitoring.collection.timeout_interval: 600000000000
[2017-08-02T16:58:01,962][DEBUG][logstash.runner ] xpack.monitoring.elasticsearch.username: "logstash_system"
[2017-08-02T16:58:01,963][DEBUG][logstash.runner ] xpack.monitoring.elasticsearch.password: "changeme"
[2017-08-02T16:58:01,963][DEBUG][logstash.runner ] xpack.monitoring.elasticsearch.sniffing: false
[2017-08-02T16:58:01,963][DEBUG][logstash.runner ] node.uuid: ""
[2017-08-02T16:58:01,963][DEBUG][logstash.runner ] --------------- Logstash Settings -------------------
[2017-08-02T16:58:01,976][DEBUG][logstash.agent ] Agent: Configuring metric collection
[2017-08-02T16:58:01,979][DEBUG][logstash.instrument.periodicpoller.os] PeriodicPoller: Starting {:polling_interval=>5, :polling_timeout=>120}
[2017-08-02T16:58:01,995][DEBUG][logstash.instrument.periodicpoller.jvm] PeriodicPoller: Starting {:polling_i


(Tim Vernum) #2

We do not update your configuration files when you install plugins.
The plugins make new configuration settings available for you to use in your configuration, but you need to add them yourself if you want to apply a value to them.

When applications start trying to fiddle with configuration files and automatically apply changes, it has a tendency to go wrong and mess everything up.

Please provide more details. What settings have you configured?

Those are the default values for those settings.


(MJay) #6

I am able to figure out this issue and it was with the format of the logstash.yml file. Is there any way to validate the logstash.yml file similar to what we have in filebeat?

filebeat -c filebeat.yml -configtest


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.