Problem while installing Marvel


#1

Could any of you help me with this error I am getting:
./bin/plugin install elasticsearch/marvel/latest

Stack trace of errror:
Exception in thread "main" java.lang.IllegalArgumentException: Could not resolve placeholder 'ES_RACK'
at org.elasticsearch.common.property.PropertyPlaceholder.parseStringValue(PropertyPlaceholder.java:124)
at org.elasticsearch.common.property.PropertyPlaceholder.replacePlaceholders(PropertyPlaceholder.java:81)
at org.elasticsearch.common.settings.ImmutableSettings$Builder.replacePropertyPlaceholders(ImmutableSettings.java:1060)
at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:101)
at org.elasticsearch.plugins.PluginManager.main(PluginManager.java:389)

I must agree that ES_RACK is an environment variable I am setting in a file called setenv and not in elasticsearch.yml.
How do I come over this error?


(Niraj Kumar) #2

What version of ES you have?


#3

It's 1.4.4.


(system) #4