Problem with config.yml


#1

Hi, I hope that my problem could be solved.
I want to output topbeat to a file.
But it is not possible for me to use file output.
Please see configuration file:

input:
period: 10
procs: [".*"]

output:
file:
enabled: true
path: "/tmp/topbeat/"
filename: topbeat
rotate_every_kb: 1000
number_of_files: 7

command:

./topbeat -test -c .yml -v

output:

geolite.go:61: INFO Loaded GeoIP data from: /usr/share/GeoIP/GeoLiteCity.dat
publish.go:222: WARN No output is defined to store the topology. The server fields might not be filled.
publish.go:234: INFO No shipper name configured, using hostname 'localhost.localdomain'

version;

./topbeat --version
topbeat version 1.0.0-beta4 (amd64)

Thank you in advance


(ruflin) #2

@Nubber The output here is a little bit confusing, as this is related to the Topology. Your config looks correct and your files should appear in the directory /tmp/topbbeat. Are there any files in the directory after running the above command?

To improve the above warning I created the issue here: https://github.com/elastic/libbeat/issues/210


#3

Hi Ruflin,

no files are inside directory /tmp/topbeat.


(ruflin) #4

@Nubber Just spotted that you use the -test flag when running topbeat. This will only test the config file and will directly exit. Can you remove the -test flag and try again?


#5

Oh yes, you are right.
There is now the file und /tmp/topbeat
But the message that comes up that there would be no shipper used, is very irritating.

Hence the issue 210 should be kept open and given out better information about that. Thank you.


(system) #6