Problem with ingest attachment plugin


(sreejith) #1

I have been using mapper attachment plugin with elasticsearch 2.4. I was using a complex mapping with multiple nested levels and inside some nested elements we had attachments. It was easy that i just need to use the type 'attachment' and the elasticsearch will automatically recognize it when i index any document.

Now I tried to update to version 5.2 and I used the ingest attachment plugin instead.

Now it is not recognizing the attachments. I tried to create the processor in different ways with foreach processor.

I am not sure how to specify the field and target field since it is inside multiple nested loops. Also the document/attachment is optional in a nested section. Also there can be multiple attachments in the document.

The mapping of the index we use is like:

I tried to create the processor as:

Please advice me how to create the processor.

Thanks in advance.
Sreejith


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.