Ingest attachment plugin installed, nodes restarted still get the No handler for type [attachment] error


I'm trying to store attachments to my ES cluster but I'm stuck at the mapping creation step. Here is my actual situation :

The ingest-attachment plugin is installed on each node :

And each nodes has been restarted successfully.

But when i try to create a mapping containing an attachment i still get the error :

ES is in 7.2v

Any idea ?


Bonjour :slight_smile:

That's not how ingest attachment plugin works.
You are trying to behave like the mapper attachments plugin used to work. This plugin has been removed.

Have a look at the documentation to see how ingest attachment works:

Thanks, for the fast answer :slight_smile:

If I'm understanding well, you don't store the attachment in the document but you have to create a pipeline for the attachment and a mapping for other fields. Then you link the attachment to the document you put in the index with the pipeline, right ?

It's a succes,

To help other, Here is the process :

  • You create your document mapping
  • You create the ingest pipeline for attachments (like here)
  • Then when you create a document you attach the document by adding the "data" field in the list of fields that takes your document (created in step 1) and add the ?pipeline=attachment in the URL.

Hope it helps :slight_smile:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.