Problem with the river-jdbc sqlite


(Franck B) #1

Hello,

I use jdbc-river to feed my ES 0.92 with sqlite datasource . Everything is
OK.

I wanted to upgrade ES 1.1.1 and there is drama , I have this error:

[ERROR][org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource]
while opening read connection: jdbc:sqlite:/data/db/maDb.db No suitable
driver found for jdbc:sqlite:/data/db/maDb.db
java.sql.SQLException: No suitable driver found for jdbc:sqlite:/data/db/
maDb.db
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
connectionForReading(SimpleRiverSource.java:133)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
execute(SimpleRiverSource.java:252)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.fetch
(SimpleRiverSource.java:227)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.move(
SimpleRiverFlow.java:129)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.run(
SimpleRiverFlow.java:88)
at java.lang.Thread.run(Unknown Source)

The driver sqlite-jdbc-3.7.2.jar is installed in the plugin directory . The
river- jdbc plugin has been updated and has
ElasticSearch-river-jdbc-1.1.0.0.jar
ES is deployed on a CentOS 6 64bit .

The river:

PUT /_river/monIndex/_meta
{
"type" : "jdbc",
"jdbc" : {
"driver" : "org.sqlite.JDBC",
"url" : "jdbc:sqlite:/data/db/maDb.db",
"user" : "",
"password" : "",
"sql" : "SELECT * FROM toto "
},
"index" : {
"index" : "monIndex",
"type" : "monType",
"bulk_size" : 50000,
"max_bulk_requests" : 5
}
}

I thought that the ES release was too recent for the plugin so I went on
version 1.1.0 putting the plugin version 1.1.0.0 . Still the same problem
...

The sqlite driver is not the problem because I did the test with a mysql
driver , I have the same problem.

In addition, I find the driver in the classpath ES . ( by ps aux | grep
elast )

I'm lost, I do not really see where the problem lies . I followed the
procedures .

It's a shame to downgrade ES and lose the benefits of Marvel .

Someone has encountered the same problem ? How has it been resolved?

Thank you for your help!

Franck

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/82fb97e4-fb5f-41ea-871e-08114feebd6e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

You must use a JDBC4 driver (jdbc sqlite 3.8.2-SNAPSHOT at least)

The "driver" parameter is ignored by JDBC river.

Jörg

On Thu, Apr 24, 2014 at 1:25 AM, Franck B f.belvallette@gmail.com wrote:

Hello,

I use jdbc-river to feed my ES 0.92 with sqlite datasource . Everything
is OK.

I wanted to upgrade ES 1.1.1 and there is drama , I have this error:

[ERROR][org.xbib.elasticsearch.river.jdbc.strategy.simple.
SimpleRiverSource] while opening read connection: jdbc:sqlite:/data/db/
maDb.db No suitable driver found for jdbc:sqlite:/data/db/maDb.db
java.sql.SQLException: No suitable driver found for jdbc:sqlite:/data/db/
maDb.db
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
connectionForReading(SimpleRiverSource.java:133)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
execute(SimpleRiverSource.java:252)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
fetch(SimpleRiverSource.java:227)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.move(
SimpleRiverFlow.java:129)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.run(
SimpleRiverFlow.java:88)
at java.lang.Thread.run(Unknown Source)

The driver sqlite-jdbc-3.7.2.jar is installed in the plugin directory . The
river- jdbc plugin has been updated and has
ElasticSearch-river-jdbc-1.1.0.0.jar
ES is deployed on a CentOS 6 64bit .

The river:

PUT /_river/monIndex/_meta
{
"type" : "jdbc",
"jdbc" : {
"driver" : "org.sqlite.JDBC",
"url" : "jdbc:sqlite:/data/db/maDb.db",
"user" : "",
"password" : "",
"sql" : "SELECT * FROM toto "
},
"index" : {
"index" : "monIndex",
"type" : "monType",
"bulk_size" : 50000,
"max_bulk_requests" : 5
}
}

I thought that the ES release was too recent for the plugin so I went on
version 1.1.0 putting the plugin version 1.1.0.0 . Still the same
problem ...

The sqlite driver is not the problem because I did the test with a mysql
driver , I have the same problem.

In addition, I find the driver in the classpath ES . ( by ps aux | grep
elast )

I'm lost, I do not really see where the problem lies . I followed the
procedures .

It's a shame to downgrade ES and lose the benefits of Marvel .

Someone has encountered the same problem ? How has it been resolved?

Thank you for your help!

Franck

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/82fb97e4-fb5f-41ea-871e-08114feebd6e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/82fb97e4-fb5f-41ea-871e-08114feebd6e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGj8PHebwZ%2Bcf-s6MsdxqPcLqDA9aF9pdaRbrj_VVGgSg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Franck B) #3

Hello Jörg,

Thans for your help !! It's working !

Franck

Le jeudi 24 avril 2014 01:25:28 UTC+2, Franck B a écrit :

Hello,

I use jdbc-river to feed my ES 0.92 with sqlite datasource . Everything
is OK.

I wanted to upgrade ES 1.1.1 and there is drama , I have this error:

[ERROR][org.xbib.elasticsearch.river.jdbc.strategy.simple.
SimpleRiverSource] while opening read connection: jdbc:sqlite:/data/db/
maDb.db No suitable driver found for jdbc:sqlite:/data/db/maDb.db
java.sql.SQLException: No suitable driver found for jdbc:sqlite:/data/db/
maDb.db
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
connectionForReading(SimpleRiverSource.java:133)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
execute(SimpleRiverSource.java:252)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
fetch(SimpleRiverSource.java:227)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.move(
SimpleRiverFlow.java:129)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.run(
SimpleRiverFlow.java:88)
at java.lang.Thread.run(Unknown Source)

The driver sqlite-jdbc-3.7.2.jar is installed in the plugin directory . The
river- jdbc plugin has been updated and has
ElasticSearch-river-jdbc-1.1.0.0.jar
ES is deployed on a CentOS 6 64bit .

The river:

PUT /_river/monIndex/_meta
{
"type" : "jdbc",
"jdbc" : {
"driver" : "org.sqlite.JDBC",
"url" : "jdbc:sqlite:/data/db/maDb.db",
"user" : "",
"password" : "",
"sql" : "SELECT * FROM toto "
},
"index" : {
"index" : "monIndex",
"type" : "monType",
"bulk_size" : 50000,
"max_bulk_requests" : 5
}
}

I thought that the ES release was too recent for the plugin so I went on
version 1.1.0 putting the plugin version 1.1.0.0 . Still the same
problem ...

The sqlite driver is not the problem because I did the test with a mysql
driver , I have the same problem.

In addition, I find the driver in the classpath ES . ( by ps aux | grep
elast )

I'm lost, I do not really see where the problem lies . I followed the
procedures .

It's a shame to downgrade ES and lose the benefits of Marvel .

Someone has encountered the same problem ? How has it been resolved?

Thank you for your help!

Franck

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/50589b9a-4293-4da1-8ed0-4a72833ac6a5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Matt Burns) #4

Unfortunately, that version of the sqlite driver does not work on OSX:

java.lang.NoClassDefFoundError: org/sqlite/NativeDB

See:

On Thursday, 24 April 2014 07:59:11 UTC+1, Jörg Prante wrote:

You must use a JDBC4 driver (jdbc sqlite 3.8.2-SNAPSHOT at least)

The "driver" parameter is ignored by JDBC river.

Jörg

On Thu, Apr 24, 2014 at 1:25 AM, Franck B <f.belv...@gmail.com
<javascript:>> wrote:

Hello,

I use jdbc-river to feed my ES 0.92 with sqlite datasource . Everything
is OK.

I wanted to upgrade ES 1.1.1 and there is drama , I have this error:

[ERROR][org.xbib.elasticsearch.river.jdbc.strategy.simple.
SimpleRiverSource] while opening read connection: jdbc:sqlite:/data/db/
maDb.db No suitable driver found for jdbc:sqlite:/data/db/maDb.db
java.sql.SQLException: No suitable driver found for jdbc:sqlite:/data/db/
maDb.db
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
connectionForReading(SimpleRiverSource.java:133)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
execute(SimpleRiverSource.java:252)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
fetch(SimpleRiverSource.java:227)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.move
(SimpleRiverFlow.java:129)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.run(
SimpleRiverFlow.java:88)
at java.lang.Thread.run(Unknown Source)

The driver sqlite-jdbc-3.7.2.jar is installed in the plugin directory . The
river- jdbc plugin has been updated and has
ElasticSearch-river-jdbc-1.1.0.0.jar
ES is deployed on a CentOS 6 64bit .

The river:

PUT /_river/monIndex/_meta
{
"type" : "jdbc",
"jdbc" : {
"driver" : "org.sqlite.JDBC",
"url" : "jdbc:sqlite:/data/db/maDb.db",
"user" : "",
"password" : "",
"sql" : "SELECT * FROM toto "
},
"index" : {
"index" : "monIndex",
"type" : "monType",
"bulk_size" : 50000,
"max_bulk_requests" : 5
}
}

I thought that the ES release was too recent for the plugin so I went on
version 1.1.0 putting the plugin version 1.1.0.0 . Still the same
problem ...

The sqlite driver is not the problem because I did the test with a mysql
driver , I have the same problem.

In addition, I find the driver in the classpath ES . ( by ps aux | grep
elast )

I'm lost, I do not really see where the problem lies . I followed the
procedures .

It's a shame to downgrade ES and lose the benefits of Marvel .

Someone has encountered the same problem ? How has it been resolved?

Thank you for your help!

Franck

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/82fb97e4-fb5f-41ea-871e-08114feebd6e%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/82fb97e4-fb5f-41ea-871e-08114feebd6e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/75917009-6962-48d5-bd1d-c964c03b7dce%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Matt Burns) #5

Ahh, I just realised that if I solve this, I just bump into the next
problem regarding the readonly flag:

Humph :frowning:

On Thursday, 5 June 2014 12:05:24 UTC+1, Matt Burns wrote:

Unfortunately, that version of the sqlite driver does not work on OSX:

java.lang.NoClassDefFoundError: org/sqlite/NativeDB

See:
https://bitbucket.org/xerial/sqlite-jdbc/issue/127

On Thursday, 24 April 2014 07:59:11 UTC+1, Jörg Prante wrote:

You must use a JDBC4 driver (jdbc sqlite 3.8.2-SNAPSHOT at least)

The "driver" parameter is ignored by JDBC river.

Jörg

On Thu, Apr 24, 2014 at 1:25 AM, Franck B f.belv...@gmail.com wrote:

Hello,

I use jdbc-river to feed my ES 0.92 with sqlite datasource . Everything
is OK.

I wanted to upgrade ES 1.1.1 and there is drama , I have this error:

[ERROR][org.xbib.elasticsearch.river.jdbc.strategy.simple.
SimpleRiverSource] while opening read connection: jdbc:sqlite:/data/db/
maDb.db No suitable driver found for jdbc:sqlite:/data/db/maDb.db
java.sql.SQLException: No suitable driver found for jdbc:sqlite:/data/db
/maDb.db
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
connectionForReading(SimpleRiverSource.java:133)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
execute(SimpleRiverSource.java:252)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource.
fetch(SimpleRiverSource.java:227)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.
move(SimpleRiverFlow.java:129)
at org.xbib.elasticsearch.river.jdbc.strategy.simple.SimpleRiverFlow.run
(SimpleRiverFlow.java:88)
at java.lang.Thread.run(Unknown Source)

The driver sqlite-jdbc-3.7.2.jar is installed in the plugin directory . The
river- jdbc plugin has been updated and has
ElasticSearch-river-jdbc-1.1.0.0.jar
ES is deployed on a CentOS 6 64bit .

The river:

PUT /_river/monIndex/_meta
{
"type" : "jdbc",
"jdbc" : {
"driver" : "org.sqlite.JDBC",
"url" : "jdbc:sqlite:/data/db/maDb.db",
"user" : "",
"password" : "",
"sql" : "SELECT * FROM toto "
},
"index" : {
"index" : "monIndex",
"type" : "monType",
"bulk_size" : 50000,
"max_bulk_requests" : 5
}
}

I thought that the ES release was too recent for the plugin so I went on
version 1.1.0 putting the plugin version 1.1.0.0 . Still the same
problem ...

The sqlite driver is not the problem because I did the test with a mysql
driver , I have the same problem.

In addition, I find the driver in the classpath ES . ( by ps aux | grep
elast )

I'm lost, I do not really see where the problem lies . I followed the
procedures .

It's a shame to downgrade ES and lose the benefits of Marvel .

Someone has encountered the same problem ? How has it been resolved?

Thank you for your help!

Franck

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/82fb97e4-fb5f-41ea-871e-08114feebd6e%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/82fb97e4-fb5f-41ea-871e-08114feebd6e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9b2744b1-d1a4-4d0f-8f01-fd954c0eafe1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6