Problem with time mappings


(Marten) #1

Hi,

I have trouble with getting a correct timestamp in my index.
Whatever I try, the timefield in my index is one hour higher than the timestamp I push into the index.

If I push this string "20170206172656596" into this mapping:

"Time": {
"type": "date",
"format": "yyyyMMddHHmmssSSS"}

I get this timestamp in ES: "February 6th 2017, 18:26:56.596"
So, exactly one hour later.

I'm running the latest version of Elasticsearch (5.2)
I'm sure it must be something with my locale settings, but I just can't find it.
Any help with this would be very welcome.

Marten


(Alexander Reelsen) #2

Hey,

internally all dates are treated as UTC. You have not specified a time zone on indexing. You might want to use a date processor to fix the timezone before indexing.

--Alex


(Marten) #3

Hi Alex,

Thanks.
I somehow misinterpreted the documentation on this.
I'got it working correctly now.

Marten


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.