Problems Installing plugin on debian


(Sindre Hiåsen) #1

Hi,

I've installed elasticsearch on a debian server. Now I try to install some plugins but have no luck.
What I've tried is
sudo bin/plugin --install ingest-attachment
sudo bin/plugin --install elasticsearch/ingest-attachment
sudo bin/plugin --install elasticsearch/ingest-attachment/latest
sudo bin/plugin --install elasticsearch/ingest-attachment/5.4.0
All of this commands only give me error that it cant install because it dont find install file

Then I tried this
sudo bin/plugin --url https://artifacts.elastic.co/downloads/elasticsearch-plugins/ingest-attachment/ingest-attachment-5.4.0.zip
And nothing happens, but no error
Tried this
sudo bin/plugin --install https://artifacts.elastic.co/downloads/elasticsearch-plugins/ingest-attachment/ingest-attachment-5.4.0.zip
And now I get:
Failed to install https://artifacts.elastic.co/downloads/elasticsearch-plugins/ingest-attachment/ingest-attachment-5.4.0.zip, reason: plugin directory /usr/share/elasticsearch/plugins already exists. To update the plugin, uninstall it first using -remove https://artifacts.elastic.co/downloads/elasticsearch-plugins/ingest-attachment/ingest-attachment-5.4.0.zip command

Then i tried to download above mentioned zipfile with wget and then
sudo bin/plugin --install file://ingest-attachment-5.4.0.zip
But then I got error
Failed to install https://artifacts.elastic.co/downloads/elasticsearch-plugins/i ngest-attachment/ingest-attachment-5.4.0.zip, reason: plugin directory /usr/shar e/elasticsearch/plugins already exists. To update the plugin, uninstall it first using -remove https://artifacts.elastic.co/downloads/elasticsearch-plugins/inge st-attachment/ingest-attachment-5.4.0.zip command

Yes there is a plugin folder, but its empty. If I try to run
sudo bin/plugin --list
I got
Installed plugins:
- No plugin detected in /usr/share/elasticsearch/plugins

So if anyone can tell me how i install ingest-attachment plugin, because this was not as easy at it should be

Best Regards,
Pål Sindre HIåsen


(David Pilato) #2

The right way is https://www.elastic.co/guide/en/elasticsearch/plugins/current/ingest-attachment.html

sudo bin/elasticsearch-plugin install ingest-attachment

(Sindre Hiåsen) #3

Hi,
Thanks for your reply. Problem is that this command dont work
sudo bin/elasticsearch-plugin install ingest-attachment
sudo: bin/elasticsearch-plugin: command not found

I dont have elasticsearch-plugin thats where I started to check. And after some work figured out to use only sudo bin/plugin

Regards
Sindre


(Javier) #4

Hello:

It looks you're running an old version of ES here (probably the one hosted on Debian repos)

I would suggest you to add the Elastic repo:

deb https://artifacts.elastic.co/packages/5.x/apt stable main
and then upgrade.

Please refer to https://www.elastic.co/guide/en/beats/libbeat/current/setup-repositories.html regarding instructions to add ES repo.


(Sindre Hiåsen) #5

Thanks for your answer.

Yes I installed first time just from debian repos.
I've deleted and installed it again, and now plugins are installed.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.