Problems with installation of the OUI filter plugin and logstash 5.0.1


(Oleksandr Kazymyrov) #1

I'm using logstash 5.0.1 on RHEL 7.3 and trying to install the OUI file plugin. The command sudo -u logstash bin/logstash-plugin install logstash-filter-oui returns:
... Bundler could not find compatible versions for gem "logstash": In Gemfile: logstash-filter-oui (>= 0) java depends on logstash (< 2.0.0, >= 1.4.0) java Could not find gem 'logstash (< 2.0.0, >= 1.4.0) java', which is required by gem 'logstash-filter-oui (>= 0) java', in any of the sources.


(Magnus Bäck) #2

It looks like you need 3.0.0 of the plugin but it hasn't been released yet. I've pinged the core team for assistance with this.


(Magnus Bäck) #3

3.0.0 of logstash-filter-oui has been released. Can you try again?


(Oleksandr Kazymyrov) #4

Not it works like a magic. Thanks for the help.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.