Proper way to configure a custom analyzer


(Ivan Brusic) #1

The syntax seems simple, but I must be missing some punctuation at
some point. I am unable to create a custom analyzer with a filter.

Here is a gist with the relevant snippet of the mapping:
https://gist.github.com/2705752

If I leave filter empty ( "filter": [] ), then everything works. If I
put in any value, the config file will not be read. Only warning is

[2012-05-15 16:00:37,718][WARN ][cluster.metadata ] [Janus]
[products-c] failed to read template
[\elasticsearch-0.19.2\config\templates\product_template.json] from
config

The eventual configuration is much more detailed, but it seems to be
failing with the filter section.

Cheers,

Ivan


(Shay Banon) #2

It seems to be an issue with properly loading nested settings in a template
when loaded from a config path, opened an issue:
https://github.com/elasticsearch/elasticsearch/issues/1960, will be fixed
shortly.

On Wed, May 16, 2012 at 2:03 AM, Ivan Brusic ivan@brusic.com wrote:

The syntax seems simple, but I must be missing some punctuation at
some point. I am unable to create a custom analyzer with a filter.

Here is a gist with the relevant snippet of the mapping:
https://gist.github.com/2705752

If I leave filter empty ( "filter": [] ), then everything works. If I
put in any value, the config file will not be read. Only warning is

[2012-05-15 16:00:37,718][WARN ][cluster.metadata ] [Janus]
[products-c] failed to read template
[\elasticsearch-0.19.2\config\templates\product_template.json] from
config

The eventual configuration is much more detailed, but it seems to be
failing with the filter section.

Cheers,

Ivan


(Ivan Brusic) #3

Thanks. It is good to know that I am not going crazy and it is a bug instead.

--
Ivan

On Wed, May 16, 2012 at 2:36 PM, Shay Banon kimchy@gmail.com wrote:

It seems to be an issue with properly loading nested settings in a template
when loaded from a config path, opened an
issue: https://github.com/elasticsearch/elasticsearch/issues/1960, will be
fixed shortly.

On Wed, May 16, 2012 at 2:03 AM, Ivan Brusic ivan@brusic.com wrote:

The syntax seems simple, but I must be missing some punctuation at
some point. I am unable to create a custom analyzer with a filter.

Here is a gist with the relevant snippet of the mapping:
https://gist.github.com/2705752

If I leave filter empty ( "filter": [] ), then everything works. If I
put in any value, the config file will not be read. Only warning is

[2012-05-15 16:00:37,718][WARN ][cluster.metadata ] [Janus]
[products-c] failed to read template
[\elasticsearch-0.19.2\config\templates\product_template.json] from
config

The eventual configuration is much more detailed, but it seems to be
failing with the filter section.

Cheers,

Ivan


(system) #4