Query edition problem kibana


(philg) #1

hello
my context kibana + ES 0.90.11 + ES Head plugin

i have some problem with kibana query editor :
i have indexed my logs in ES, and displayed in kibana using basic queries .
Perfect !

i need more complex queries on a max_bitrate field ( integer)

for example, i need this query --> 300 < max_bitrate <1000

using ES head plugin it works i see the result, with raw json query like
this
{"query":{"bool":{"must":[{"
range":{"rglog3.max_bitrate":{"gt":"300","lt":"1000"}}}......

but then how to put in the query editor of Kibana to get the query
works ?
i did not succeed

any clue , or pointer to doc will be great because i cannot find
thanks

philippe

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ac40cafe-1acd-458c-8699-908da4baa870%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Binh Ly-2) #2

You'll need to use the query_string syntax:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/query-dsl-query-string-query.html

It should be something like:

rglog3.max_bitrate:[301 TO 999]

or:

rglog3.max_bitrate:>300 AND rglog3.max_bitrate:<1000

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0353c6c5-6c54-4c43-ab1a-4c51e7f66843%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(philg) #3

thanks ok, understood now
it works
philippe

On Friday, March 14, 2014 7:13:28 PM UTC+1, Binh Ly wrote:

You'll need to use the query_string syntax:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/query-dsl-query-string-query.html

It should be something like:

rglog3.max_bitrate:[301 TO 999]

or:

rglog3.max_bitrate:>300 AND rglog3.max_bitrate:<1000

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6e123f5f-0f17-4e66-9539-8e718da821a4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4