Redis output and missing fields


I've been stuck with the Beats / Redis / Logstash configuration for several weeks and maybe someone of you could help me. Currently I have implemented Elasticsearch Stack with Docker so that the output of the Beats use a Redis container as a buffer. Apparently everything works correctly but when loading prebuilt dashboards in Kibana I always get, among others, the same error: "field" is a required parameter. After reading many posts about it I discovered that there is lost information, why?

On the other hand, if I choose Elasticsearch as an output to the Beats (filebeat, metricbeat, etc.), everything works correctly. Any ideas? Then I copy some information of interest:

Host operating system: Ubuntu 16.04
Docker version: 18.09.5
Elasticsearch Stack version: 6.7.2

Thank you very much to everyone for your help.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.