Reduce minimum_master_nodes without starting enough nodes

I set minimum_master_nodes to 100 instead of 10. :confused: Now my PUT
_cluster/settings call doesn't work anymore. Can I reduce
minimum_master_nodes somehow without actually spinning up 100 nodes?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e840c746-2393-4df9-8029-6404e80b0a5e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Andre,

Sadly you need an active master to change settings that were introduced
through the API and the min_master_nodes settings update caused the master
to step down and prevents a new one from being elected. I think this is
trappy and I opened a PR to protect against it
: https://github.com/elasticsearch/elasticsearch/pull/8321

You can recover you data by wiping the cluster state files from disk and
letting the indices be imported (i.e., dangling indices) but it's tricky
and very sensitive to mistakes. Let me know if you want to try that out.

Cheers,
Boaz

On Thursday, October 30, 2014 5:51:54 AM UTC+1, André Hänsel wrote:

I set minimum_master_nodes to 100 instead of 10. :confused: Now my PUT
_cluster/settings call doesn't work anymore. Can I reduce
minimum_master_nodes somehow without actually spinning up 100 nodes?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/33c9dc18-021a-4e1d-9d12-092e2b4a91b7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.