Reindex error: Failed to parse content to map


#1

I followed the instruction in this page to manually reindex the Kibana index to get ready to upgrade our Elasticsearch server from 5.6.7 to 6.x.

The first step (Set .kibana index to read-only) went ok, but I got an error message when performing the second step (Create .kibana-6 index). This is the console output I received:

{
"error": {
"root_cause": [
{
"type": "parse_exception",
"reason": "Failed to parse content to map"
}
],
"type": "parse_exception",
"reason": "Failed to parse content to map",
"caused_by": {
"type": "json_parse_exception",
"reason": "Unexpected character ('"' (code 34)): was expecting comma to separate Object entries\n at [Source: org.elasticsearch.transport.netty4.ByteBufStreamInput@3d567acd; line: 5, column: 6]"
}
},
"status": 400
}

The command I ran is identical to the step 2 example in the instruction other than adding "index.format": 6 and "index.mapping.single_type": true under settings. Please see the screenshot below.

How can I fix the issue? Thanks.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.