Reindexing requires reboot of the server/VPS


(Vojta Mareš) #1

Hi, as the title says my issue is a bit weird as well as confusing.

I do not use the "update index" feature - we drop the whole search index and then we create same index with new data again.

Since I boot VPS for first time it usually works fine without any issues, but for any other later reindexing it does not work.

I am using Elasticsearch 6.2 and elasticsearch-php v6.0.1 (^6.0).

I tried clearing app's cache, manually dropping index via curl, reconfiguring Elasticsearch to have data in different folder, etc. I did not found a solution.

Note: there is nothing in app logs, elastic logs or syslog either. During the indexing process app is responding with "OK" and when done everything should be ok and working fine. But it is not.

So on Czech development event I had a chance to talk to an more experienced developer (they are using AWS Elasticsearch service) and I have ask them if they do have this issue and if so how did they solved that?

The answer was quite suprising - we have the issue, we didn't fix it - we launch new instance of ES - index stuff into that and then shutdown the old one.
Well it works well with zero downtime (miliseconds at max) but I can't go to the cloud...

I have only one instance of ES and I don't have enought RAM on DB server to try to have tiny cluster... And I can't reboot neither of them at will since they are production servers that must run on 99,999% uptime.

I can provide full logs of ES if it is necessary.


(Vojta Mareš) #3

bump, has anyone faced this issue before ?


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.