i have the following sequence of python api calls to ES.

from elasticsearch import Elasticsearch

but I see an error message 
AttributeError: 'IndicesClient' object has no attribute 'reload_search_analyzers'

any ideas will be appreciated.

Hello @chari

I think you're getting this error because you're using the Python Elasticsearch client version 7.2 or older, while this API was first introduced in Elasticsearch version 7.3+

In particular, it seems be present in 7.5.1 or 7.6.0

The cluster must be in version 7.3+

Hello Luca,
Thanks for your reply.
I am using elasticsearch 7.3.
ok, I will move to 7.6.

The cluster can stay on Elasticsearch 7.3.
The Elasticsearch client must be at least on 7.5.1.
But we recommend to align Elasticsearch & Client versions in general.

Thanks for the info.


doesn't seem to be there in 7.5.1 either.

AttributeError: 'IndicesClient' object has no attribute 'reload_search_analyzers'

i had not confirmed that my elasticsearch client was indeed running 7.5.1. After confirming that I find that the command works !


1 Like

Glad it worked! Please mark the answer as solved if possible

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.