Remote skip_unavailable?how to set?


(qu) #1

Follow the instrument in Cross cluster Search, use

PUT _cluster/settings
{
"persistent":{
"search.remote.cluster*.skip_unavailable":true
}
}

reply as below:
"error":{
"type":"illegal_argument_exception",
"reason": "persisitent setting [search.remote.cluster*.skip_unavailable], not dynamically updateable"
"status": 400
}

elasticsearch version is 6.0

Anybody known how to solve this problem?


(qu) #2

even set this configuration by elasticsearch.yml, still cannot work...


(David Pilato) #3

Did you restart all the nodes?

Do you have an error message at startup? What is it?


(qu) #4

yes,after i configured the setting in elasticsearch.yml, then failed to restart the node and got the exception as below:
unknown setting [search.remote.cluster*.skip_unavailable] please check that any required plugins are installed, or check the breaking changes documentation for removed settings


(David Pilato) #5

You can not use * but need to set the real cluster alias name.


(qu) #6

thank you for reply.

i didn't use *, but used explicit words.
BTW, i've tried many names to eliminate name's influence.


(David Pilato) #7

Oh. Sounds like you are not on 6.3 but 6.0.

This feature is not in that version. See https://www.elastic.co/guide/en/elasticsearch/reference/6.0/modules-cross-cluster-search.html


(qu) #8

yes, i've solve the problem by upgrading version to 6.1 and tested fine.
Many thanks for your help.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.